More Steam Help

Hi everyone,

I’ve looked through the FAQ and searched for other threads to help with my problem. Sadly I could find no solution to my problem, so I am posting a new thread.

The problem is simple: I’ve recently installed Comodo firewall, and I cannot get Steam-related games to connect to the internet. Steam will connect, after I allowed it through the popups from Comodo, but I cannot find servers to connect to.

The program has been allowed full access in the applications monitor, both Steam.exe and the numerous hl2.exe 's. Moreover, I’ve opened the many necessary TCP and UDP ports for these applications. However, I believe Comodo blocked off part of Steam without my prompting, for some reason. I tried allowing invisible connections and skipping advanced security checks on all apps and parent apps too.

Here’s more information:

-Comodo Firewall Ver.
-DSL internet connection.
-WinXP SP2
-Logged into system as Admin
-Other Security app: AVG Free Edition
-Security App recently uninstalled: Zonealarm Pro (never had problems with Steam and ZA)
-Custom Rules: allowing in/out TCP and UDP ports for HL2.exe and Steam.exe

Here’s screenshots:

Thank you for your help!

[attachment deleted by admin]

Hi Shokanshi, welcome to the forums.

Unfortunately, I cannot view your posted screen shots… clicking on the images to get a better view just goes to ImageShack’s site.

However, perhaps’s Day of Defeat Source CFP set-up will help.

Thanks for your suggestion kail. Unfortunately that didn’t do the trick either :frowning:

I changed the first post by simply linking to the images’ URL. You should be able to see them now.

Yes, that’s better. I can see what is wrong now… Network Monitor rules (according to PF) should be for DoD Source…

TCP/UDP In on Destination Ports 1200,27000-27015 & 27020-27039.

Your Network Monitor rules are missing the 1200 port and include ports 27016 to 27019 (which they shouldn’t) and specifies the ports as Source ports rather than Destination ports. ie. it is currently reversed. Easy mistake, have done it myself more than once.

Also check CFPs Log (Activity). You can use the Log as guide to what rules you need by seeing what has been blocked. Also CFPs Log can be Exported to an HTML file (right-click on the Log). Open the HTML file with your default browser and use a simple click-drag-select, Copy ‘n’ Paste to post example Log entries here.

PS It should be an IN only rule. The Application Monitor rules for the application deals with the out-going stuff.

I attached the log, kail. I’m attaching a new one now.

I tried what you suggested and changed them to destination ports, with source ports set as [any]. Still didn’t help, can’t find servers or connect to the steam friends list server. And I did have port 1200 there. I didn’t see what you said about ports 27016-27019 anywhere…

[attachment deleted by admin]

I missed the Log you posted… I was in a hurry, sorry. Wow big Log.

The last log you posted had lots of Inbound Policy Violation’s against UDP ports 1026 & 1027 from various source IPs. These ports are typically used by Windows Messenger services. Inbound hits, like this, are possible spamming attempts. Windows PopUP Spam, aka Messenger Spam or Broadcast Spam is a spamming technique which delivers simple text messages via the Windows Messenger service. This is unrelated to the MSN Instant Messenger application. High volumes from a single IP source indicates a possible worm infection. I don’t think these ports are anything to do with DoD/CS Source/Steam… unless someone has set up a DoD/CS server to use these ports.

There are some blocked Inbound Policy Violations against Multicast broadcasts from (Router or other LAN system?) to Nothing to do with DoD/CS Source/Steam.

A few Outbound Policy Violations (ICMP = PORT UNREACHABLE) going to the internal LAN IP Not sure what these are about… these are typical messages associated with P2P applications. But, I guess it depends on what is & what its relationship with is. Not sure this it anything to do with DoD/CS Source/Steam either.

But, I couldn’t find any DoD/CS Source/Steam related blocks in your Log. However, it might be because they’re using non-standard ports, there are lots of complaints on the web relating to CS & HL Servers in this regard. I also found some differing rules to those of PortFoward’s (not that it should matter, since I didn’t find any blocks of that type anyway)…

Protocol TCP, Outgoing, Local Address , Remote Ports 27030-27039, Remote Address , Allow Protocol UDP, Local Address , Remote Ports 1200, 27000-27015, Remote Address , Allow

Different terminology is used because these rules are for Outlook (I think). But, the direction is different for the 27030-27039 ports. These will be handled by CFPs Application Monitor. But, they also suggest that you restrict the rules further by specifying the Steam Servers that you’re using.

Thank you for all your help kail. I’ve looked this up with the extensive Steam support website. I tried deleting the exes from Comodo’s permission list and getting it to re-learn… still nothing. I’ve tried other online games, such as Guild Wars. Once Comodo learns to trust it, it’s fine. Comodo’s got trust issues with Steam :frowning: