Missing Dependency when trying to install

I am trying to install Comodo Antivirus for Linux on my Ubuntu 20.10 Linux machine. I downloaded the cav-linux_x64.deb and double clicked on it.

The installer started installing, but exited with a message “Missing Dependency”.

Does anyone have an idea what those missing dependencies may be and how to resolve this issue?



Update 1: I tried running it from command line too. This is all I get:

 $ sudo dpkg -i /home/myusername/Downloads/cav-linux_x64.deb
Selecting previously unselected package cav-linux.
(Reading database ... 269598 files and directories currently installed.)
Preparing to unpack .../Downloads/cav-linux_x64.deb ...
Unpacking cav-linux (1.1.268025-1) ...
dpkg: dependency problems prevent configuration of cav-linux:
 cav-linux depends on libssl0.9.8 (>= 0.9.8m-1); however:
  Package libssl0.9.8 is not installed.

dpkg: error processing package cav-linux (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:

So it appears to be missing libssl0.9.8. I tried installing that package:

~/Downloads$ sudo apt install -y libssl0.9.8
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libssl0.9.8 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl0.9.8' has no installation candidate

Update 2: I determined the correct version of libssl for Ubuntu 20.10 is libssl1.1, but that’s already installed on my system:

sudo apt-get install libssl1.1
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libssl1.1 is already the newest version (1.1.1f-1ubuntu4).
libssl1.1 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.

So I am basically out of ideas now. Any help from anyone?

Same issue, same results. Anyone have a solution??
-My System-
Operating System: Linux Mint 20
Kernel: Linux 5.4.0-54-generic
Architecture: x86-64

What I find fascinating is that I see similar posts that were made as far back as 2018 yet not a single response from a support team member.

Yet when I try contacting support directly through live chat or support ticket system they immediately close the ticket answer say you have to post here for their Developers to see and response to it.

It’s almost like they don’t want you to use their Product!

I presume you know the last release was 2013 since that time nothing, a few users tried to make it last longer.

I did ask to move this section to archive a few years ago (3-5 years), I was told then that something new was coming.

From the lack of anything by now I would say this product is dead, will ask again to move to archive.


I was not aware of this, nor does the site say anything about it. Thanks for letting me know.

Are there any other Antivirus software you recommend for Linux?

I use maldet there a few others which be more recent.


From what I read it may be looking for older version than what I have on Linux Mint 20? I have same issue, any answers yet that I cannot find?

There is Clamtk and Clamav (Gui Interface) but I am not so sure it is better than Comodo?