Missing Buttons on Update Dialog v3.0.17.304

Running Win Vista x64 with CFP downloaded new about a month ago.

When my WinXP box automatically updated to CFP, I checked my Vista box and found it had not updated. I tried to run Updater from the Miscellaneous settings screen. It starts just fine but shows a text box at the top saying “Please click on ‘Start’ button to initiate the update process.”. There is a 2nd text box at the bottom saying “Updater uses Internet Explorer’s Internet connection settings to deliver your updates.”. In between is nothing but empty gray space.

Anyone have any thoughts?

Hi JackSprat

I am not running vista but I think that you will need to make sure you are running as administrator before you can use the update button.

Welcome to the Comodo Forums


When I try to check for updates the dialog box shows but none of the buttons. Interestingly they are obviously there as if I click in the right places everything happens as it should. THis is on Vista Ultimate.


Can you give more information? And maybe screenshot of that dialog box?



Running under Vista Ultimate - had the same problem with the previous version. The buttons are there but you can’t see them.

Image attached.


[attachment deleted by admin]


Also have AVG Anti-virus installed. And had the same bug on a different machine under XP SP2. Processor is Intel Quad 2.44 .

Thanks again

Glad someone posted a screenshoot.

Now I wonder “Why I see a windows 2000 dialogs on Vista? :o” please fill in the informative gaps.

i have the same problem.
Attaching a screenshot with a muchsaying name ‘Comodo Firewall Pro - v3 Updater on Vistax64u.jpg’.
I am logged on as Admin.
Basically the update feature does not show a button to initiate an update.

[attachment deleted by admin]

Must be a Vista problem I think as XP Pro shows the three buttons at the bottom. (Start, Cancel and Help).

no buttons to see on this update frame.

Please somebody confirm that issue (screenshot by kutaccount) is on v3.0.18.

while moving the update frame to the side of the screen I coincidentally launched the Comodo help, which opened on page ‘Check for Updates’???
Apparently the buttons are somehow there, just not at all visible. Not even a caption or border, no text or greyed out text, nada, nothing, niente, niks. Found the update button’s location…
I suppose it has to do with skinning or Windows Themes, cause I have a Vista classic look, ukno, a Win95 look and no memory eating theme or skinthing.

This annoyance happened since the first v3 beta I tried.

Look at the help file where the buttons are supposed to be… go figure…

[attachment deleted by admin]

v3.0.18.309, and various older v3 buids I tried.

Running the Comodo Memory Firewall (64bit), the Update window has a rather same look yet works, to show what’s missing.

[attachment deleted by admin]

Version: Vista x64 Pre-Sp1