Memory usage of 500Mb+ by cmdagent [M366]

With the latest version (6.1.275152.2801) I have huge memory (and cpu) use on Win7 x64 by cmdagent.
I can kill the process to resolve the problem until it returns.
It can be as high as 500.000 kB

Thank you very much for your issue report.

We would very much appreciate it if you would be kind enough to edit your report to put it in the standard format and add any additional information requested, as this will make it much easier for the developers to diagnose and fix the problem.

The reasons we need all the information in the format, though they may not seem directly relevant to the issue are explained here.

If you are able to do this we will forward this post to the format verified board, where it is more likely to get looked at by developers. You can find assistance using red links in the format and here. If you need further help please ask a mod. If you do not add the information after a day or two we will forward this post to the non-format board. If this happens we will tell you how to rectify this if you wish to.

In the current process we will normally leave it up to you whether you want to make a report in standard format or not. However we may remind you if we think a bug of particular importance.

Many thanks again


PM reminder sent


I changed it as you wish, but look at the last attachment, for me (and others) this is completely unreadable.


A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:- Very reliably (see attachments)
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:- I don’t know when CMDAGENT should start (or stop)
  • If not obvious, what U expected to happen:-
  • If a software compatibility problem have U tried the conflict FAQ?:- No software compatibility problem,as far as I know
  • Any software except CIS/OS involved? If so - name, & exact version:- No other software except CIS/OS involved, as far as I know
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
  • Fix: kill process, until it starts again (and you will notice, high cpu and memory)
  • Always attach - Diagnostics file, Watch Activity process list, dump if freeze/crash. (If complex - CIS logs & config, screenshots, video, zipped program - not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration:- See CisReport

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
  • No Hips
  • Have U made any other changes to the default config? (egs here.):- Firewall Program rules On
  • Have U updated (without uninstall) from a CIS 5?:- No
    [li]if so, have U tried a a clean reinstall - if not please do?:- No, and I will not do a clean install of my system.
    [/li]- Have U imported a config from a previous version of CIS:- No
    [li]if so, have U tried a standard config - if not please do:- No, and I want control over in- and outgoing traffic
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:Win 7 (dutch), all updates, 64 bit, No UAC, Admin, No V.Machine;
  • Other security/s’box software a) currently installed b) installed since OS: a= Malwarebytes, Superantispyware, Antilogger free, Autorun detector, EMET (done without, same) (Hitman Pro), Sandboxie b= as a)

[attachment deleted by admin]

Sorry but we do need the prompts, othwise it will take devs ages to read your report, so they may just skip over it.

Please copy between the dotted lines of the format post, then paste and fill in the answers after the colon.

It’s much easier than it looks!

Many thanks


I changed it as you wish, but look at the last attachment, for me (and others) this is completely unreadable.

You have my sympathy! The mods have repeatedly requested a web form and automated data gathering from Comodo, but they presumably feel other things are higher priority

This leaves me with few options:

  • Post just a text format, and no formatting. Results are very difficult to read for QA
  • Post just the pretty print version, which looks bad, but actually is reasonably easy to use, and is very readable by QA. That’s what I have done
  • Post plain text and pretty print versions. Then people tend just to use the text version which QA find difficult. Also people complain vigorously that there are too many formats. But maybe I will go back to this.

You can always press ‘preview’ when editing to get a readable display. Entering information is just a matter of typing after the colons! All the formatting work is done for you. Red links lead you to help.

Best wishes


Please check what have entered for B.7, is that correct?

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


I believe it is, see attachments with running processes.

Could you just confirm please what memory usage measure you are using.?

I don’t really understand what you are asking, but I hope the attachments can help.

[attachment deleted by admin]

Yes I think I worked out that your earlier images that show 500MB+ are using Windows task manager in standard layout, if so then it is ‘Private Working Set’. The ones you just posted show only 250MB which is less striking.

About the amount, that is correct.
It is not constant, and I keep killing the process.
I don’t know when it runs and why it runs.
What you see is the moment I make the screen print, that is all I can do at the moment.

I am not a technical guy, more on the organisational side, so I don’t know if it is ‘Private Working Set’, but I believe you :wink:

About cisboost.sdb, see attachment.
(I cannot attach in a PM)

[attachment deleted by admin]

To make more clear for you what I see I made 20 (little) screenshots of what I see.
I don’t know where it ends, I killed the process after the last shot.

[attachment deleted by admin]

Hallo, as I wrote in the PM here attached the output of Sysinternals - VMMap.

[attachment deleted by admin]

try turning off superantispyware especially tea timer in it, it has been known to interfere.

I turned off the real time scanner of Superantispyware, but no difference.

I have been thinking about this answer to my problem.

If this is the solution after understanding all information I have given to you, there is only one solution:

(and for Comodo, somebody less to feed)

Please do not take Languy’s suggestion as Comodo’s response to your bug. Languy is a volunteer forum moderator, not an employee of Comodo.