Memory Access Violation in CIS.exe for everything

I’ve had problems using CIS for a few years (program not opening; can’t close; etc), but ignored them. Finally I had enough and decided to do a clean install of the program, but now it doesn’t work at all.

  1. Uninstall of previous version didn’t work so I used the clean uninstall tool.
  2. Downloaded fresh CIS installer. Disabled chrome and dragon from installing, denied yahoo as home page. Selected only AV and Firewall to be installed.
  3. Only firewall got installed, no AV.
  4. Tried uninstalling and reinstalling, same issue, so I just left the Firewall installed.
  5. Whenever I try to open ‘settings’ I get a read memory access violation error for cis.exe. Settings never opens.
  6. Tried opening Waterfox x64 (latest), got another memory error for cis.exe. Waterfox never opens.
  7. Tried forcing firewall to exit, got another memory error for cis.exe. CIS doesn’t close.
  8. Restarted computer and tried 5-7 again, same results occurred.
  9. Uninstalled Firewall.
  10. Booted into my laptops diagnostic tools. Ran all the memory tools - no issues found in memory. Ran every other diagnostic (cpu, harddrive, mobo, etc), no issues found.


I haven’t followed these instructions yet as I have the program uninstalled (since I practically cannot do anything due to the memory errors from cis.exe whenever opening a program / cis). I am posting here first in hopes that there might be a solution available that I have not tried, then I’d look at debugging/logging the errors.

Win7 x64 latest; all drivers up to date; Laptop is a Thinkpad T430S (I5-35xx; 4gb ram); unsure if bios is up to date; only other security product is malware bytes but that isn’t set to run automatically (only as needed).

Thanks for any feedback.

Have you tried installing Comodo on a clean install of Windows? An OS can get pretty corrupted over time.

Hi SomeGuy69,

Thank you for reporting, could you please provide us the below detail for investigation.

  1. CIS version ?
  2. Have you installed any other security software along with CIS ?
  3. Kindly share us the screenshot of read memory access violation error for cis.exe.