Matter of urgence- bootloader, settings, key, data corrupted.

Up until this point comodo has been great, no problems, no dispute that the trust wasn’t there.
Placing matters of security into other people’s care isnt really security when it turns around to grab you by the balls is it? i entrusted comodo as other products seemed stable, so i tried the encryption app.

no doubt its my fault entirely for not researching adequately enough, some things you take for granted and assume its covered, because they’re obviously proffessionals? i take responsibility for not backing up the drive… but no1 figures this would happen to them…

my problem is kind of tricky, and text on a forum can never do my frustration any justice in this situation im in as a result.

i have 3 hdd’s. c, d and e.

  • i proceeded to encrypt d drive with SHA256 and blowfish config. selected password AND key authen.
    before begining the task, CDE prompted me to format my flash drive.

  • proceeded by using windows to format the drive for use- CDE was idle in the mean time.

  • i was prompted to select a location to save the keyfile- which i had later realized had gone missing.

  • after i saved the keyfile and the drive was formated, i returned to CDE window to find that the encryption process had already started. i waited several hours for the process to complete. and it completed successfully as i watched the bar until the end, although with that said, i did notice heavy activity coming from the d drive as though i had performed a large scale search or manual deletion of everything on the drive. hopefully you know what i mean.

  • at this point, i navigated to my d drive to find that the drive was accessible as normal, nothing appeared to be any different and all of my data was readable and writable.

  • upon reboot, i was asked for a password, as i was typing it i noticed the flashing cursor wasnt moving, so i hit the delete key as many times as needed to clear the password i had typed in, thinking the keyboard wasnt working or perhaps there was something wrong, again since the screen wasnt registering any pressed keys.

  • after typing my password and booting into windows, i discovered my drive was inaccessible, and i was concerned about being prompted to format the drive. formating just isnt an option. i figured maybe everything may have been fine, CDE was doing its job, but still felt funny about being prompted to format because that shouldnt occur.

  • loaded CDE and tried to authenticate myself using the credentials in the settings, but a msg ‘encryption subsystem’ error appeared. upon browsing this forum i saw some "sure solutions’ to the problem i was having, but nothing worked. i followed the instructions to remove the bootloader and i even formated according to the guys repsonses on the forum. still no joy.

  • uninstalled, reinstalled. and nothing.

  • bios settings are fine.

  • only after i had removed the bootloader did i realize the flash drive WAS NOT configured as a key, so why did it proceed with the encryption task?

can anyone shed some light as to how i can manipulate this scenario into a win?

if it is an authentication issue, then i must restore the bootloader. how can i do that?

if i start a task for another drive, lets say a blank drive, with the same settings as used for d drive, can i fool comodo into authenticating d drive at boot time??

with no bootloader, a reinstalled CDE, missing original key how can i recover my data??
i generated a new key file and placed it on my flash drive, but is this effective practice or does CDE need to format the drive especially so the contents cannot be viewed?

does anyone know of any 3rd party brute force apps that allow me to view the data? as long as i have the information and passwords etc, shouldnt this be a simple task?? why is comodo the only company that can apparently save the day?

please help.

payment an option if you think you can help.

oh and im using windows vista ultimate x64.


If the encrypted partition is not available in windows explorer this means that the authentication was not performed. Please keep the USB keep the USB key plugged in during boot time. Check the BIOS setting to be sure that the USB port is enabled during boot time.

Ty for the reply.

It is appears this issue has occured from my own stupidity.

The problem is that i didnt expect CDE to create the usb key so quickly, it didnt click that the file size of the key would obviously be small, not the entire capacity of the flash drive (LOL)
… I formated the drive as CDE was writing the key, or as i was formating the drive using Windows, CDE didnt get a chance to successfully create the key.

either way, i selected both password and key for my encrypted D drive… and the only single original key wasnt issued properly… hence the lock out.

the question beckons,

Im ■■■■■■■ right??

Can the data be accessed only using CDE? can i use any application to access the drive if i input the required credential information such as encryption type etc?

i made a backup of the key, however, im unable to get it onto a flash drive, it appears as though CDE writes other information to the flash drive, hence making it inaccessible (“format now”), it doesnt work when i simply transfer the file to the drive.
also, in the options, there doesnt appear to be a way to create a flash key using the backed up key file, and i obviously cant make a copy the flash drive because the drive isnt encrypted and theres nothing to copy.

can someone please help? please dont tell me theres no way to recover the drive… this is the last hurdle for the home stretch… success or failure??