Manual steps to create zones and set rules (FOR OSAGE)

Hope this helps,
Ewen :slight_smile:

[attachment deleted by admin]

and in PDf format … :smiley:

[attachment deleted by admin]

To Panic,

Who has long gone beyond that extra mile to be helpful—and thank you for that.

I note the previous format was not readable by my computer but the pdf format comes through perfectly. By in large the steps look almost idiot proof simple.

But am already confused by two things.

  1. Given that my two computers have network ip’s of and, I note your network definition of Osage’s network says a range of ip’s of to Which means that the third designator is different. My ip’s have a third designator of 0 and your rule has a third designator of 1. Is this correct or could it be a typo on your part?

  2. I am confused on which computer to apply the rules to. Given that I have a ICS network, there is a host computer and a client computer. Do I apply the rules to the host computer only, the client computer only, or to both host and client computer? I am guessing host computer only but do not want to be making any wrong assumptions.

It will be a day or two before I get a chance to try it, but otherwise it looks really well written.


Hey Osage,

As per my PM to you,

  1. DOH! I forgot to use IP addresses appropriate to your LAN in the example. Wherever I have and, please change these to and for your rules.

  2. These rules should be entered on both PCs, but the HOST PC is the critical one as it connects to the internet. If CFP is on both PCs, then the rules should be on both.

Ewen :slight_smile:

Followed the Pdf to the letter but I still can’t get my LAN to work properly unless I completely disable the firewall.

Me too. Followed the instructions in the pfd; rebooted; prints still fail.

The firewall event log is showing
System | Blocked | UDP | | 137 | | 137 is my network printer, is my PC.

Any thoughts would be appreciated.


Yep, same thing happening to me. I also tried to create specific rules for those UPD ports but to no avail, Comodo still blocks any kind of communication between my Pc’s :-\

Hang in there for a couple of days, guys. :wink:

As being one of the first to raise the networking issue with CPF3, it does not pleasure me to see that I
am not the lone ranger. There is no pleasure in misery loves company and I think we all want to see
CPF3 work for us in the networking area.

But what I find weird is, what happened to the planning that went into both comodo 2.3 and 2.4.
Where the networking wizards just automatically and seamlessly recognizing our networks and got them working. What happened to those in CPF3?

But we should also recognize CPF3 is incrementally update able—without the need to uninstall and then reinstall the next revision to get any program revisions and upgrades.

So question—can some comodo update be capable of restoring the ability of comodo ver 3’s ability to recognize and configure networks automatically?

Watch this space. :wink:

Any idea how long we need to watch this space? (:WAV)

Just a little longer.

I have also followed the doc and my home network is still not working. I never had any problems with version 2, But now I’m totally stuck.
I would like to know if someone actually has managed to create a home/trusted network with version 3, or do I need to downgrade.


Hi Panic,

Can you do a doc just like the one you did for Network for ICS but for Network custom Policy for Applications, I’m just starting to learn and get to grips with the custom policy network rules for applications and a guide like that might help some ;D

P.S for some examples it would be great if you could do illsutrated examples for how to edit custom policies for (plural:) WEb Browsers, P2P apps, Trusted Applications, System Applications, the last one system application i take to mean an app we trust and regard as a vital 3rd party component to our system that works on the system level.

thanks (V)

Obviously they have, since CFP V3 has been downloaded more than 1.1 million times. If networking wasn’t allowed, I’m pretty sure we’d have approximately 1.1 million complaints. :wink: On one PC at hiome, I have 4 network zones defined and working correctly and I did nothing other than use the principles outlined in the doc.

If you are following my doc from this post, please bear in mind that you cannot follow it verbatim, unless your network is an exact replica of mine. You will need to determine what IP ranges are used across your LAN and modify the suggested rules accordingly.

Ewen :slight_smile:

May so be, and good for all those who have managed get the network running. Me on the other hand have not, even I have followed the steps described in the doc. I figured out that when I try to browse a shared directory, firewall fires blocked action for System application. How can I remove it to be fired when using home network?
see attached pdf for part of the config and firewall alerts.

I would love to see home network wizard…


[attachment deleted by admin]

Hey jouni,

Can you please attach a screenshot of your network rules?

Ewen :slight_smile:

I have been following this thread, but I just can’t figure out the problem this guy is having.
I wish I could help, as I have a network with W2K server running Active Directory and NAT, and Comodo works just fine on the workstations.
I can only surmise that he clicked “No” to a popup and now he is being locked out.

I’ve followed the same instructions and I’m having the exact same problem v3.276. I can get out to the web but I can not access any network shares on my home or work LAN even after creating zones for each and assigning the appropriate rules. The workstation running Comodo can not access any shares nor can any shares on it can be accessed by other workstations unless I deactivate the firewall.

The key to diagnosing problems like htese is to have a look in the logs (FIREWALL - COMMON TASKS - VIEW FIREWALL EVENTS). Is there anything pertinent there? If so, can you please post an extract here.

It can work. It does work. Hang in there.

Ewen :slight_smile: