Malware "Remove fail" error with New Comodo fw D+

hello everyone i am new to this forum. Want some help. I was using eset antivirus 4.2 and comodo firewall D+ version 5.3. I tested my firewall with a malware , the firewall scanned it on Cloud and detected it as malware and gave me options " Clean" and “Ignore”. On applying “Clean” the malware was removed from my system.

****************************Now here is the problem: **************************
Yesterday i switched to latest comodo firewall D+ 5.9 . On my upgrade i decided to test the new fw D+ module with same malware tested before. this time it scanned on cloud and showed an error " Remove fail" and asked me to go for online assistence :-. I dont know how to fix this bug? .

Ya i searched it online and found out that the Qurantine folder is missing in comodo free firewall so the malware was not removed.

I dont want this bug to be in my system again. Should i create a qurantine folder? will that fix the problem?
if so where and how to create the qurantine folder?

Or is there any other way so that the new firewall will work just fine ,like the old comodo firewall 5.3 worked for me?

System: core i3,4GB ram ,win7 32 bit system.

Hello & Welcome to the Forums

Can you please answer these questions:

  1. Were you testing the malware on your real computer?
  2. Are you using the full CIS Suit or just the Firewall?

In addition, could you please try reinstalling the software.


I am using comodo free firewall with D+ . I am not using the CIS. i have eset av 4.2 with me. Ya i have tried to reinstall the comodo firewall but it didnt work for me. :(. the malware was blocked but not removed from my system. But the comodo firewall 5.3 used to do that for me. Is there any way i can fix the problem?

Ya the malware was tested on my real computer not vmware

Could you take a screenshot of the message please and post it, just to make sure we are starting from the right place.

Best wishes


Yah the 1st image show that threat is been detected .

when i click on the "Clean button " this is what happens shown in 2nd image

n second image show that the threat cannot be removed.

actually the previous firewall comdo firewall 5.3 used to remove this threat in a second. But new firewall doesnot do that .

The malware is present on desktop itself… n not removed in this case.

[attachment deleted by admin]

And ya the threats were detected by Comodo firewall 5.10 by scanning on cloud and the file was found to be unsafe, i use comodo firewall Defence + version 5.10

please hellp me with the problem

Thanks could you click on “malware list” on the remove fail dialogue and show the results. See if it says what malware effects have been removed and what have not.