Malware prevents CIS installation - how to solve?

I know there’s malware on this system; it causes occasional error messages. When I try to install CIS 4.0 it goes almost to completion, then says “There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor”. It appears to be at the step “Registering antivirus service”. When I click OK it rolls back everything.

I tried reinstalling (after reboot) with just the antivirus component - same result. I tried installing in Safe Mode, but (as often happens) it could not install.

If I could get Comodo installed I’m sure it would clean up the malware. How to get past this problem? ??? ???

try installing free version, if you can install it, update it and run a quick scan, tell me how many things it finds. Maybe you can attach the log for me that pops up when it’s done. Remove anything that it finds.

A better option would be to run a full scan. If you think you’re infected, you want to be thorough.

I ran a quick scan which found threats and removed them after reboot. CIS4 still would not install. Same problem. It reached “Registering antivirus shell” and then said “There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected…”.

I ran a full scan which reported 0 problems.

I have attached the log. What to do??

[attachment deleted by admin]

I would run this clean up tool;msg259617#msg259617 then reboot. Now downland the msi package from this links ( the 60MB one) and try to reinstall;msg388177#msg388177

I downloaded the uninstaller batch file and I downloaded the installer package directly from the specified link. It proved identical to the installer package I was already using.

I ran the uninstaller batch file and rebooted. I retried the install. The problem remains exactly the same - it gets to almost-the-end and then says there’s a problem.

What else would you advise?

check this out are you running as administrator? also what is the error number you are getting?

YES I am running as Administrator. No, I am not installing “ArcGIS”, whatever that may be. The system is running Windows XP, so UAC is not an issue. CIS4 installed fine on a couple nearly identical systems. Alas, still no success.

try some of these fixes Loading...

Can’t do that until later today - meetings. I do point out again that near-identical systems didn’t have any problem with CIS4 installation. It’s got to be the malware that’s causing trouble, so solutions aimed at “reasonable” problems with Windows Installer are almost certainly barking up the wrong tree.

Some vendors offer a non-install web-based scan, or a bootable CD image that scans outside Windows (to avoid interference by malware). I guess no such from Comodo?

comodo offers a cloud based scanner, check it out here

AHA! That will be something great to try later today. Thanks.

another one you can also try is hitman pro, they give it to you free for 30 days and it uses 4 different av engines to scan with.

The Comodo Cloud Scanner is 100% useless. It detected four malware processes and advised “Talk to a live technician”. I wasted a half-hour getting to the point where the technician said “OH, since you are not a paid subscriber I cannot help you”.

It also claimed to find thousands and thousands of junk files and Registry errors. I don’t believe it; seems like inflated figures to force paid subscription. I’m not impressed.

I will take the advice to try Hitman Pro (tho’ I’ve not been impressed by it in the past). Thanks!

really, from what I know you get 30 days for free, so they should have helped you out. Well I would say really try hitman pro, that should at least let to be able to install CIS.

Nope, they were very clear - if you don’t have a subscription ID you don’t get malware-removal help. And it seems I’ve used Hitman Pro on an earlier incarnation of this system - re-imaged completely, but the SID is still the same. SO I have to use NewSID before Hitman Pro will again let me have 30 days. I’m workin’ on it… Hoping that NewSID still works to reset the current Hitman.

well you can also try trendmicro online and bitdefender Bitdefender Free Antivirus - Download Software for Windows

SOLVED. My NewSID chicanery successfully allowed a 30-day use of Hitman Pro and after that CIS4 installed correctly. ;D ;D ;D

ok good to hear, now that cis is installed, update it and do a full scan. Make sure nothing was missed.

I have to raise my eyebrows to this story again.

CIS a full featured security system but can’t make it happen to install itself because off malware ??? We first have to get another software bundle from another manufacturer to remove threats so CIS can be installed. Then the advice is to run a full scan with CIS to check for something missed… 88)

Now tell me why is cis so good? :-\