malware detected in my comodo.

I’ve been having problems with Trojans on my pc. So I bought firewall security pro. I ran Adaware scan and it found this. deepscan:generic.malware.SIWN!BVg.41A79A2D in this location. " =>c:\program files\comodo\comodo internet security\cavwp.exe (VMRD 0x1d650000 + f7000) [1664] (pgexec dump) ". Adaware failed to remove it. Is this a false positive, or is something amiss? (Sorry in advance if this isn’t the right area of the forums to post this. I wasn’t sure where would be appropriate)

Hi LRuin,

Can you send us the detected file with details about the environment on which this event occurred and a screenshot.

Thanks and regards,
Umamaheshwari M

I can send you the cavwp.exe file if thats what you want. The environment? I’m not sure what you mean, do you mean you want to know what programs i had running at the time? I had comodo dragon, comodo internet security pro, and adaware (in compatibility mode) running

I tried to post the file that the malware was detected in, and the website wouldn’t allow me to upload it.

This is the screen shot from adawares scan.

Hi LRuin,

please submit the detected file at below link

Thanks and regards,
Umamaheshwari M

I submitted it. thank you for the help btw.

I restarted my computer in safe mode ran adaware, came back after a few hours, and found my computer restarted. After logging in I was greeted with this message.

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 1033

Additional information about the problem:
BCCode: 1a
BCP1: 0000000000041284
BCP2: 0000000010B60001
BCP3: 00000000000205D6
BCP4: FFFFF70001080000
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

This is not a Comodo issue you need to tell Adaware to fix the false positive, also running more than one security software is not recommended as it will cause issues. As for the crash you need to take note of the faulting driver if it is listed at the blue screen, and you need to collect the generated memory dump as long as you have kernel memory dump set for write debugging information under system properties.

Did Adaware quarantine cavwp.exe when you ran it in Safe Mode? If you did please restore cavwp.exe. Then add the Comodo folder to the exclusions of Adaware and submit the detection to Adaware as a false positive.

Thank you for the reply. I was thinking it was probably a false positive. I plan on contacting adaware soon. That error was for a faulty driver? Oh, I thought it might’ve been related. Thank you for the help, and sorry if I’m being inane. I’m not a expert with computers. lol

I had no idea of the results of the scan while it was in safe mode. I don’t think the log results were even saved by adaware. But earlier today I actually let a scan run while I was at work. This time it actually did delete it. However the file still exist in c:\program files\comodo\comodo internet security. So, I guess it wasn’t actually deleted. I will be contacting Adaware about it. Thank you all for the help. You all are awesome.