Major problems with Comodo PFW

I will try and remain neutral, but my first impressions of this software are not positive!

I was enticed to download and use this software after the leaktest on your site. I admit to using Sygate PFW and figured it might be time to update since it’s no longer supported. What I wanted was a firewall with advanced rulesets so I could allow programs like Outlook to ‘only’ connect on port 110, or Internet apps to only use ports 80 and 443, rather than just have a yes/no system. Comodo seemed to meet these requirements. By saying I wanted to have a rules based firewall, I’m trying to show that I’m not the average home user that requires ‘point and click’ operation and will spend time setting up an application to do specific things.

So anyway, downloaded the installer, uninstalled Sygate (after burning an image of the files to CD) and rebooted. Confirmed that all references were removed from the registry and rebooted again. Installed the software using the power users options to limit the assumed default options. Rebooted (again!) and found that even though the firewall was alerting me to apps trying to access the net even when they were allowed, they could not connect. I also noted that my bluetooth and wireless network indicators had gone missing from the system tray. I tried launching Outlook and was prompted to use the dial-up connection that is reserved for when I am on the road and not at home (ie no wireless network to connect to) I tried setting the firewall to ‘allow all’, and nothing. I tried setting a rule to allow everything, nope! I tried exiting the application, still nothing. Even with the program not running I was still being blocked from the network. I uninstalled the program, rebooted and everything was fine again.

So I tried to reinstall using the default installation options. Same problem. I uninstalled, rebooted, read through all 20+ pages on the forum, got slightly worried about the problems this SWF has playing nicely with other apps, and tried again. This time I kept the default installation directory. Reboot, and at least now I can connect to the net.

Again I allowed or disallowed programs based on what the information in the pop-up window said, fixed the AVG problem and went to the test page on the Comodo website. Ran the test program and ■■■■ up comes the same web page as I had with Sygate (different text as I typed a different message) so it would seem that nothing has changed! Two minutes later I got the pop-up warning box. Bit late after the horse has already bolted!

I uninstalled the software, got a new copy of Sygate from (thank heavens for archive sites!) and reinstalled Sygate. I copied the files from that backup CD back to my computer and now everything is running perfectly.

So my problems in summary:

  1. Very hard to install and get working, finally only managed it blindly clicking through the default options on the installation page.

  2. Firewall not compatible with AVG without a fix (the program will auto allow preset apps, so why not preset AVG with this little fix?!)

  3. With nothing changed from default (remember that was the only way I could get it to work!) it failed the very test that induced me to download it, so why should I have faith that it will do anything else it claims?

If I had paid for this software, I would be seeking a full refund for false advertising! Over the years, I have gone from McAfee Firewall (hey I was new to this then and an attempt at security is better than nothing!) ZoneAlarm Free, to Tiny (Kerio) PFW (I wanted the rules options that ZAF didn’t have) and now to Sygate. I have never had even so much as a hint of the trouble that this software caused and am just grateful that it was easily removed from my PC without any trouble (actually the only painless act in the whole experience!)

It’s a shame that this software left such a bad impression as I actually really liked the UI, but at the end of the day, looks come second to functionality. Amusingly, I don’t seem to be the only person having these problems, so it’s clearly not just my system configuration…

Hi and wolcome to the forums.

I am another CPF user but will try to answer at your questions:

  1. The problem you had on connecting was caused probably from activating the option Secure the host while booting. This can cause problems especially with bluetooth connections. Another option that can cause problems sometimes is the one “Monitor DNS queries”.

  2. Firewall is compatible with AVG with this “little fix”. Since you said that you like configuring the firewall yourself and not just using yes/no options, I don’t get why this is a problem. (it could be at a novice user)

  3. at which test you reffer? Most probably it will pass the test if you disable “Automatically approve safe applications”,which is a feature that help novice users for not getting a large number of pop-ups.

ps. If you “play” with CPF for 1-2 days probably your first impressions will change. Personally the first time I installed CPF, I had to uninstall it after an hour, because verion 2.0 blocked my pc. The developer team of comodo do their best to fix bugs and resolve issues and are fast on releasing updates. And is the only developer that interacts with us, the users, by asking us what to improove and which new features we wish to be implemented on future updates.

Hi and thanks for replying.

  1. The connection problem was (and still is) nothing to do with either of those options. They were both unchecked. I find it wierd that the laptop will connect to the network, it’s just that all network traffic is blocked. I also find it strange that even with the program not running at all (even disabling autorun at start-up so it never executes) I still can’t access anything. This would suggest something that it does to a file on the install being a problem?

  2. Isn’t really a problem, but thought it was worth mentioning as a feedback point. A novice user would probably be lost at this. Even as an experienced user, one would think that the default options for an application that is known to cause problems would be set to minimse those problems?

  3. The test I was refering to was the CPIL test that claims on the download page that this is the only firewall to pass with default settings. When it didn’t, I was concerned! No applications were automatically approved. When I was asked if I wanted to allow applications to be approved or not, I followed the reccomendations and approved ones marked as safe (even if they were ones that I normally would have blocked without trouble). However, since this firewall claims it will pass this test using the default settings, why would allowing it to automatically approve safe applications be a problem? In fact why would it fail the test just letting it do whatever it wanted automatically since it is supposed to be able to pass this test by default using its default (hence automatic) settings. If I wanted to tweak it to pass this test, why bother using it at all, I could just tweak my existing set-up to pass the test! It seems a bit silly that it would automatically approve an application which will then cause it to fail the very test that it claims to be impervious to!

I don’t think this software is for me, despite trying several installation options, I have still not got any access to my bluetooth and wireless control panels, and I can’t accept icons just dissapearing. It seems a bit on the buggy side unfortunately, I want software that plays nicely with others, not something that is restricting me and can only be resolved through unistalling as the problems don’t go away even if it isn’t running. I don’t have a problem setting up rules and playing around to restric things, but I do have issues with spending hours setting up something to be unrestricted and then having to go back and see how much it can be ■■■■■■■ down…

But again, thankyou for taking the time to respond.



I really appreciate you taking the time to try our software.
I am sorry that CPF did not exactly meet your needs.
Can you please help us build the CPF to your liking?
We need your help in identifying how we should improve it and noone knows better than our users. So can you pls help us?


I’m not sure what help you would like, but these are the issues I had once actually getting the software to play nice and let me connect to the internet. What worried me initially was the fact that even with the firewall disabled it wouldn’t let me connect to the internet. If something is switched off or set to allow all, I would have thought it would do that.

Bluetooth, no control panel icon in the task bar. There was no way of bringing up the control panel, but I could still click on existing shortcuts to connect to other devices (mobile phone and PDA). The firewall seemed to have blocked the Bluetooth settings application from running. I have a Dell Internal 350 bluetooth card and am using the Bluetooth Stack for Windows by Toshiba version 3.03.02(D).

As above for the wireless, totally unable to access the settings and status manager. I have an Intel PRO/Wireless 2200BG card and runing Intel PROSet/Wireless configuration tools.

Not overly impressed that I had to play around with settings to get AVG to work properly. Since the firewall has known safe applications, could you not add this application and have its default settings set to allow it to actually work? The end user can then play around to limit it as needed.

The real killer for me was when I tried the CPIL test again using Opera V9.00 build 8502. The program downloaded fine, ran fine and when I input my test message, up pops the window showing my firewall had let this info leak out. About 30 seconds after this I got the warning from my firewall that CPIL was doing this and did I want to stop it…well a bit late since the information was already out there! Upon reflection, it’s possible had I tried it using microsoft internet explorer as an auto recognised ‘safe’ application, this may not have happened. But then again, the firewall did warn me it was happening, but it was after the event and 30 seconds is a long time for a transmission to occur before security software jumps in to prevent it. I would hate to think how much info as plain text could be sent in that time.

What would have made this app more likely to stay would have been if it had worked more easily out of the box, so many references on the forums to settings that should not be used otherwise major problems occur such as the secure host one. Well if that causes so many issues, why have it?! If it didn’t prevent me from using applications for no apparent reason, though I suspect it’s linked to the difficulty I originally had getting any network traffic, ie that some files are modified that my system didn’t like, otherwise if the problems were limited to issues when the software was running, they should have gone away when it wasn’t. I’m not sure I like the idea of having files modified so that software has total control even when I tell it not to. Least uninstallling rectified this, unlike some other software where you practically have to do a clean install of the OS.

Please ask for any further info you would like. I’ll stick around and try this again in a few months, when a few more revisions have been made.

Hey Steve,

Thanks for the comprehensive feedback. Comodo ARE a user responsive company and these issues will undoubtedly discussed.

Melih, Steve has raised a very good point.

If the fix for AVGEMC.DLL is known, and “Monitor DNS Requests” is known to cause issues and “Secure host while booting” likewise causes issues, why aren’t the fixes included in the installation defaults and AVGEMC.DLL included in the known safe app (with skip advanced disabled for this app)?

This would ease the install for most users, simplify lan connections and allow AVG to do it’s voodoo.

What do you think?

Ewen :slight_smile:

Hi Guys,

Tomorrow we will try to make a beta release with which all these problems will be solved. Yes we needed to change defaults. And there will be many improveents(like fast user switching, AVG issue etc). I will post here the complete list of changes whenever we release.


Great E! Hopefully this’ll free up some time for the support guys if these default-based issues are fixed in the install.

Ewen :slight_smile: