MAJOR install error!!! System down.

After installing Comodo I installed the certificate and clicked OK. It started to do something (progress meter) and I also got a message to update the Launchpad. I clicked OK do start the update. Then I got a message that the launchpad was updated and asking to reboot. I didn’t answer, because the certificate verification was still going. Then I got a Windows XP warning that a couple of Windows files had been replaced and do I want to reinstall the originals from the CD. Once again I decided to wait until the certificate verification thingy was complete.

Eventually it seemed like it was, and I clicked OK for XP to fix the files, but it said my XP CD was wrong. I can’t rember the exact sequence now, but I tried to reboot but I can’t boot to windows because I get the error that the hall.dll is missing. OK, so I figure I’ll do a repair, so I stick the CD in and boot from it. But I get the “Windows is inspecting your hardware configuration” message for a second, then the screen with Windows Setup, but that’s all. It just sits there. So I can’t boot.

Does anyone have any ideas? I certainly never expected complications like this from an antivirus program. (:AGY)


This is a known issue with beta 1 and beta 2 versions of CAVS. It is being worked on to find the cause of the problem.

There is a thread about this here:,3735.0.html

I’m sorry you were affected by this issue. To resolve you will need to reformat your HDD and reinstall windows.


WHAT??? That’s the only option? That’s not something that was caught in alpha??? And you’ve known about it for a month and didn’t have ANY warnings up??? Some kind of warning when there’s such a MAJOR issue would be nice from a company that touts “Creating Trust Online.” How about pulling the thing to prevent this from happening to other people, or at least putting up huge warnings and making it more clear that this is beta software (I didn’t even notice it was). I would expect a problem like this to have not made it to beta-- this is insanely major and this “free” program will now cost me over a hundred dollars (because I can’t just reformat my drive, I need stuff on there) plus a couple of days work, AT LEAST. (It’ll cost me far more than any non-free antivirus program!) Plus I have to deal with MS about my license, and contact about 10 other software vendors about licenses. And of course, some of them are small companies who won’t be around because of the holidays, so I won’t be fully up and running again till January. This is criminal. Absolutely unacceptable.

Here is a webpage that might help you out:

It has some good info that might save you some money, hopefully.

hope this helps you



The HAL.DLL issue has only affected a handful of users and Comodo have been unable, to date, to replicate the circumstances that cause the file deletions/changes to occur. Users that have been affected are helping Comodo track it down, but we haven’t cornered it yet.

With all due respect (and please bear in mind that I’m the one that first raised the issue with Comodo and still suffer from it, albeit very intermittently), running BETA software on a production system is like waving a red flag at a bull. Doing so without having a backup of any sort is like blind bull fighting.

The BETA downloads are not available from the CAVS website - they can only be downloaded via the forums. They are not pushed onto users, users (that’s you and me) have to make a conscious decision to download and install them (on a production system or onto a test system, however we see fit). The beta downloads are located in a part of the forums called “Beta Corner”, which, to me, pretty clearly indicates the status of the software.

You could try running the Windows recovery console. The first two commands I used were “fixboot” and “fixmbr”. Once these had been repaired, I copied “ntldr” and ntdetect" from the installation CD to the hard drive and then extracted and copied “hal.dll” to \windows\system32. There were other files missing, but these were sufficient to get my system to where I could boot in safe mode and then copy files from the CAB files to replace the missing files. It took a while, it wasn’t easy, and I now regularly backup my system using Paragon Drive Backup, so I have a complete image of a working system, in case it happens again.

Hope this helps,
Ewen :slight_smile:

I downloaded it from the main site, not from the forum (v1.1). I didn’t realize it was a beta or I wouldn’t have installed it. Anyway, I’ve been a beta tester for various programs since 1992 and for the past 7 years have been an alpha & beta tester as well as a tech support person. I’d expect that by the time a program goes to public beta that the problems are more along the lines of crashing or features not working properly, not taking out your whole system.

When there’s a potential that it can take out your whole system (and this is a KNOWN ISSUE), you either remove it from the web site, or you put up a big warning. But it’s still up there. So far this program has done more damage to my system than any virus ever has.

Jasper, thanks, I saw that page yesterday but didn’t try it yet. I’ll try it today.


People have been having trouble with that friggin’ hal.dll issue since at least Win2000 and MS either can’t find the cause or they won’t find the cause. They love this type of situation because it makes the outside dev people look like they don’t know what they are doing. Of course, it is never MS’s fault if you’ve ever had to call their paid support. Their take on the problem is “we didn’t do it so tough luck”. I have seen numerous other big name non-beta programs do the same thing on one install and then turn right around and not do it on another install on the same machine. I have myself had the problem once on Win2000 when I was dual-booting and I was just as pissed off as you. Something in that .dll gets screwed up if the right conditions exist and then things get corrupted or deleted. Do a google search and go to the forum links that it brings up and you will see nothing but posts about the hal.dll issue from all kinds of software installs gone bad or from just simply booting up the PC. Those posts go clear back to 2000 and still nothing is fixed from MS. Sorry for the rant and I know this doesn’t really help you but I do feel your pain.

Since you are familiar with support, another thing that you might try is to make a BartPE bootable disk from your windows install CD. If you make it on another machine then make sure you have your CD in the drive before running the program and it should give you the choice of choosing the CD files to build it instead of the OS that is installed on the machine(installed OS files from another machine won’t work). I don’t know if you would be able to access the harddrive or not from this but it might be worth a shot.


Here’s the status so far:

As per the web site that Jasper and I found, I put the drive into another system and was able to retrieve my hal.dll from the backup. (It was gone from System32.) Then I put it back into the original sytem and it booted up. But I needed to re-activate Windows, and had to do it over the phone, because the network connection wasn’t working and it wouldn’t let me get past the activation screen to try to fix it. Reactivating went fine and I seemed to have been up and runnig. But there were a couple of DLLs missing, like, strangely for the mouse and my Nvidia card, and it couldn’t find them when I had it look. (The mouse works, except for the wheel, so at least I can still use it in the meantime.)

That’s all fine, I can reinstall those from newer versions online, except that I can’t get that machine online. And I can’t even run Device Manager because it says that module is missing. I’ve never had that happen before. Anyone have any ideas?

Hey Fred,

Please understand there was no offense intended in my reply. I want to get to the bottom of it as much as you - more so, since it has happened to me five times and it really s**ts me (and no, I didn’t say it suits me. LOL)!!!

Can you please PM me with your email address and I’ll send you some tools that will create a profile of your PC (no personal info required, please edit log before returning). I’m sending these to all affected by the issue (there’s only 7 out of a couple of hundred thousands installs to date) to try and nut out a common hardware or O/S and or service pack factor.

We’d be grateful for any assistance. 7 out of 600K is still too many, but no-one has been able to nut this out, whether its caused by the software, the OS, the hardware or some horrible combination of these factors.

Out of curiousity, did a Windows update occur immediately before or during the install?

Thanks in advance for any assistance you can offer. Comodo are not resting on their butts on this one. The latest beta ( has a troubleshooting log that records the process ID that deletes any system file. This has been built in specifically to catch this.

Ewen :slight_smile:

Hey Fred,

Youre lucky, try getting a system back up when it won’t recognise a standard keyboard! LOL

The hal.dll corruption is a real bugger to work out, because its impact on affected systems varies from system to system, instance to instance. I have one test box that is affected and all five times there have been different system files missing. The one common factor that always goes bye-bye is hal.dll. Strange that a software install can induce this, particularly on the hardware abstraction dll.???!!!???

I’ll do some digging around and see if I can work out how to get Device Manager back.

Ewen :slight_smile:

OK, PM sent. But I’ve noticed another weird problem with my system now. When I right-click on any shortcut icon the Windows installer comes on and tries to install software (things I already have). Only after I hit Cancel a couple of times do I actually get the context menu. Anyone have any ideas about this?

EDIT: The above problem has been resolved. I uninstalled and reinstalled the programs it was trying to install.

Now if I could get the Device Manager back again…

Device Manager is “devmgmt.msc” and should be located in C:\WINDOWS\SYSTEM32.

Hope this helps, Fred.

Ewen :slight_smile:

Great, thanks!


Hi Ewen,

Don’t you want to have a PC profile by me? Or doesn’t that work cause I installed Windows on a new HD and use the old one as data disk?

Just want to help,

Certainly George, I’m trying to build profiles from anyone who has had this issue. Can you PM me your email address and I’ll send you the diagnostic tool.

Cheers and thanks for the offer of help,
Ewen :slight_smile: