low id in emule - help needed

Hello everybody!

I believe I’ve tried everything to get a high id with emule, but with no results.

I forwarded the router ports properly, and turning of the firewall gets me a high id. (so the problem should be with CIS)

I’ve configured CIS as advised here on the forum. I believe no problem here.

Having checked to log all blocked traffic, I get several blocked attempts of incoming connections on my chosen UDP and TCP ports, but related to “Windows Operating System”, and not emule.exe.

I’m using Windows 7, and the system firewall is turned off.

Anyone have any ideas?



I believe my problem is related to this https://forums.comodo.com/empty-t51394.0.html

But this is happening with emule running!! So why is not the traffic directed to emule and instead is treated as Windows Operating System (and blocked)?

Should I allow this traffic? How can I do it?



So, everyone is on holiday?

Am I the only one having this behaviour?


Did you run the Stealth Ports Wizard in the past to block all incoming traffic? Can you show a screenshot of your Global Rules?