Lost connection CIS <-> Dragon Browser


after updating Windows to 1803 without any other problems so far, Im faced with the following problem:

The connection between Comodo Dragon Browser and CIS is broken. That means: In the CIS widget (“Run installed browser in the container”) the installed Comodo Dragon Browser is listed like the other browsers. After clicking on the Dragon icon nothing happens. When I start the Dragon Browser and click on “switch to virtual mode” I got the message, that I have to install CIS. Obviously CIS and Dragon Browser dont know each other.

In the past I have had the problem once before. The only one solution was to reinstall CIS. I do not want to reinstall CIS after every big Windows / Comodo Update, so my question is: Is there a solution to fix this or to repair the broken connection manually? (in the registry or like that!?)

I’ve been running 1803 since April 30th . . just tried running Dragon from the Widget and same result as you. I can’t be certain that it was 1803 in my case, as I installed Dragon some time after installing CIS and that may be the wrong way round, although rather strange if it is!

I just re-installed CIS and all works fine now however and I think that may be your only option, unless some other solution is posted

Hi Viper94,

Thanks for reporting. We will investigate the issue.

Kind Regards,

Glad to hear that.
If you need more information from me, just come back to me. Im happy if I can help. Hopefully it is just a small (but irritating) issue that can be fix easily in the next release(s)

The fix for this issue is coming in 2nd beta. We have released 1st beta version today.



I’ve also had the same issue several times (for at least 3 years now) and the only solution has always been to reinstall CIS from scratch. It’s a minor bug, yet, quite annoying! Especially since dragon is my default browser and I navigate through the sandboxed widget browsers most of the time.
I really hope this time around it does get permanently fixed!


Please verify fix of this issue in latest BETA v6580:


Appears to be fixed with this Beta. I will give it a lengthy test tomorrow

Edit: All fixed . . . I’d clean installed the CIS Beta2. Uninstalled Dragon this morning then after reboot, installed in an alternate path. After reboot, the CIS - Dragon connection is restored and everything works as it should