Lost all Network Adapters

I posted over at dslreports as well, but adding more info here.
I have the paid version of the standalone Comodo FW. I also had HauteSecure running, but decided to uninstall it as it was causing too many problems with sites I frequent in Europe. Immediately upon uninstalling it, Comodo permission pop-ups began. I kept hitting “Deny” as I assumed it was coming from HauteSecure.
Lo and behold, I realized entirely too late that what I was blocking was my own ISP here in Bulgaria.
To make a long story short, I could not delete the rules to unblock my ISP and decided to uninstall and reinstall Comodo. I still could not get back online, so I did what any frustrated and “semi-savy” user would do - I started picking through the registry to kill off Comodo for a clean install without the block rules.
It took a few days to realize, that what I obviously did was to kill my Network Adapters in toto. Anywhere in the registry where I found “Comodo” - I deleted the key. I did not realize that Comodo installed network devices until it was too late.
I spent three hours in a chat session with HP yesterday trying to reinstall my Broadcom and Realtek adapters to absolutely no avail. I have been at this for nearly a week already. No matter which course I take to reinstall the drivers, a Windows error occurs, stating the driver was installed, but
“Windows encountered a problem installing the driver software for your device. Windows found driver software for your device but encouintered an error while attemting to install it - Realtek - The system cannot find the file specified,” and also
"The device is not working properly because Windows cannot load the drivers required for this device. (Code 31) "
I am attaching a .txt doc of the chat session I had with HP. I have spent days uninstalling and reinstalling these drivers to no avail.
In the first few days, I tried reinstalling Comodo FW, but it would not reinstall. I used my original file and when that failed, I tried CIS, with only the FW option enabled.
After ending the session with HP yesterday, I went into Safe Mode and managed to reinstall CIS with just the FW enabled. I was delighted to see it had reinstalled this time, but unfortunately, this ■■■■■■■ things up even more. Now I am getting blue screen errors and can only boot into Safe Mode.
This is my post at BBR if anyone wants to see some of the errors encounterd:

If anyone has any idea of the next step, please advise!
Also, should I go into safe mode and UNinstall Comodo again, as the installation is what appears to be causing the blue screen. The message goes so quickly, all I see is that some driver did not unload or load properly.
Also - is there an option to extend the blue screen message in msconfig boot options so I have a chance to read it in its entirety?

Thanks for any help.

Completely forgot - running Vista Home with SP1 on a Compaq Presario laptop. Had Bitdefender AV along with the Comodo FW, but uninstalled BD as well. Virus scans and malware detection turned up nothing. Checked for everything and the machine is clean.

Edit to add: I successfully uninstalled Comodo through Safe Mode, and the Blue Screen error has ended. I can boot into the desktop again.

[attachment deleted by admin]

You have some system restore points left to try?

Hi Eric,

Of course, that was the first option, but I had downsized the default size of the Vista restore file (sometimes not good to tweak things), and was not able to restore before the crisis point.

Are there any FAQs with the registry locations of Comodo FW? What I may have done was to delete a few Legacy keys that had “Comodo” listed (yes, I changed permissions on some of them) when I first started having problems.

What I do not understand is why Comodo will not load now. After loading it in Safe Mode, I started getting blue screen errors, which I am still getting, although at least I can boot into my desktop again and everything else seems fine. I am afraid the more I play around, the more the system will degrade.

Thank you.

It may be moot at this point, but in the future (once this issue has been resolved), you could backup your entire system on a 200G drive. Should any serious issues again arise, you will always be able to restore to a known good point.

Hi John,

I did back up on a 500 GB external, but that was quite a few months ago…

All files are currently backed up, so I will likely have to reinstall from the Recovery panel as that is the only option available with Vista. The current OS has been running trouble free for two years, so not too much too complain about. I would, however, still like to see if I can recreate the registry keys. I normally back up before deleting, but this was the one instance I blew it…

I had a similar experience last week (not with CIS, but another application that crashed my system). All attempts at normal recovery failed. Good thing my system backup was only a week old. I lost very little.