Logging out/logging in turned my system into a brick after update

Windows XP SP2, all updated. Also running BOClean.

I run with 2 limited users as well as Administrator (“run as”). Before the upgrade, Comodo was causing timing problems with my taskbar on login where the icons would fail to show every so often.

After upgrading to the latest version by allowing the automatic update to run, it erased all of my rules due to its “conversion”. Thanks a lot.

Then, after I got it the way I wanted it (“paranoid mode”/“highest alert level”) and all quieted down, after I made sure that all the applications I needed would run correctly, I logged out.

When I tried to log back in, all I got was the desktop background, nothing else, no icons no taskbar. Ctrl-Alt-Delete gave me the Task Manager that showed that nothing else was running under the user, including explorer.exe.

When I tried to run explorer.exe (or any other executable, for that matter), I got a message box to the effect of: “Windows can’t find the device, file or directory. Permission problems. Access denied.”

No process would execute. Lovely. Nice brick of a computer. Great job, guys.

Since I couldn’t get explorer or the task bar or any other process to execute, I couldn’t disable Comodo

What I ended up having to do was boot up on a Knoppix CD, remount the system disk to read-write, and rename away the Comodo directory, the cmd*/inspect sys drivers, and guard32.dll so they wouldn’t execute on startup. Then I got my system back.

Once I had a system, I renamed back to correct names, and uninstalled down to the bone using instructions posted here to completely clean off Comodo, including BOClean.

I am currently running Windows firewall and have my icons back solid.

I seriously hesitate to ever try Comodo again.

Why was this moved here? Is this not a bug? I had to boot up with a Knoppix CD to recover. Is the bricking of my system somehow my fault or lack of knowledge that I need “help” for?


It doesn’t clear whether problem happened by CF’s fault. To make sure, do a clean install and leave default settings of CF. If Windows boots normally in this case, it may be user’s mistake. No offence is intended, it happens sometimes.

More details are needed to troubleshoot the problem and to find out whether it is a bug or not (pls see here for details).

When bug will be discovered (if any) this topic will be moved to Bug Reports, don’t worry.

Thanks for cooperation.

P.S.: Next time boot in safe mode to troubleshoot/uninstall/fix CF. It is easier than using LiveCD :wink:

When I tried to log back in, all I got was the desktop background, nothing else, no icons no taskbar. Ctrl-Alt-Delete gave me the Task Manager that showed that nothing else was running under the user, including explorer.exe.
Interesting. I've got a couple of images with 3.0 and when I mount them, I get pretty-much the same results. I was just equating it to a faulty ATI image, but after reading your post, I wonder. BTW, are these mounted images from ATI/Ghost/other BU SW, or are these on a cloned drive or is this the original OS on the original HD?


I had the very same problem on my desktop computer after updateing CFP to I have Vista Ultimate 32 bit SP1 RC Refresh. I had only a blank background, I was able to start the Task Manager by pressing CTRL+ALT+DEL but I was unable to run Explorer.exe.
However I discovered that I was able to run CFP.EXE (C:\Program Files\COMODO\Firewall\cfp.exe). After the firewall started, I was able to run Explorer.exe too. Unfortunately every time I logged out or restarted windows I had to do the same thing again: run CFP.EXE then Explorer.exe from the Task Manager. I suspected the D+ to be behind these strange events, so I disabled it completely. Now I am able to use Windows as before, but without the D+ features.

Althogh CFP runs fine (with D+ disabled) I am still unable to run the scanner. Every time I click on Scan My System, the scanning window shows up with a nice scanning animation, but nothing else happens, the scanning never starts.
I dare not to upgrade CFP on my laptop now. :frowning:

I had the same exact problem on XP SP2, except that “all security permissions” were denied to all users when the system failed, and I could not access any executable or system files, control panel, etc. Even rebooting in safemode I could not access or uninstall the new 3.0 version. I had uninstalled 2.4*** and rebooted, then installed the newest version of Comodo FW Pro 3.0.

The firewall seemed to perform well, and allowed me to update windows, etc. and rebooting several times. However, after logging off and back on as “user” and the security issues kept me locked out, even denying me permission to start and restart my computer. The Windows message on log out also stated that “other users are logged into this computer and logging out may cause them to loose data. Are you sure you want to log out?” (Even though I was the only user at the time.)

Eventually the hard drive could not be accessed at all and I never was able to get back into that install. After running a hard drive test with the manufacturer’s utility, the test indicated the hard drive had failed. I couldn’t even access it for a low level format with the utility.

Thinking I had just had “coincidentally” had a hard drive failure that had caused my problems, I purchased another HD and installed a clean copy of WinXP Pro SP2. This time I did all updates before installing Comodo FW Pro 3.0. The installation seemed to go well, and again I was able to install programs, drivers, etc. that is – UNTIL I TRIED TO LOG OFF AND BACK ON AS THE SAME USER… and again I was denied access privileges to ALL Applications and System files, with the “you do not have permission to *****” All it would allow me to was to log off user … with the same warning message about other users being logged in and them loosing their data.

I tried to reboot, and tried logging in and out a number of times. I even tried to log in as the main Administrator and the same issues … NO ACCESS to anything.

Following that, I immediately rebooted into Windows Safe Mode and uninstalled the Firewall successfully this time.

Upon rebooting following the uninstall I regained access to all of my files, programs, and system files.

This may be a “normal experience” for some, but after one hard drive replacement and hours of frustration rebuilding my system I have gone from loving Comodo to really having my doubts about this new version. To me this is a BUG problem in program that should be addressed.

At this time I’m not inclined to try reinstalling it again. (:SAD)

(If anyone reads these things, perhaps a tech or someone with similar experiences could let me know their solution).

Until then I’ll run another firewall that doesn’t crash my system.

I’m pretty sure that this release has some major problems. This particular issue seems to be with explorer. After I got the update, other users on this computer have been afflicted, while I have not because I don’t use explorer as my shell.

Running Vista 32 bit - had the same problem, did not have permission to access anything, yet I am logged in as administrator