Local Apache Server not accessible with CPF ON [Resolved]

Greetings everyone,

I recently switched from Norton Internet Security to Comodo’s Free Firewall. It’s running much smoother and is great so far.

I’m also running an Apache server (Easy PHP) but other than myself, no one can access my server from outside. When I change the security of the firewall to ‘Allow All’ everyone from outside can access my server no problemo.

Now I have added the apache server to the known list and allowed all connections to it, but it still wont work. With Norton I did the same and it used to work there.

Anyone have any tips as to what I can do? I don’t want to uninstall this great firewall, but I do need to run my server. Every help is appreciated!

Thanks in advance,

I have no experience in running a server, but you can try a few things.
First I think you have to check the "skip loopback TCP in security/advanced/misc
If you are behind a router, you should create a trusted zone in security/tasks
Restart the firewall
If it still doesn’t work, try to turn off just network monitor. If it works, then you have to make a rule in there, for the ports used by your server.
You can also check the log in activity/logs and see what ports that is trying to be used, but is getting blocked. It could be ICMP too.
To get more pop ups, and have better control in the beginning, you can go to security/advanced/misc and uncheck “do not show alerts for apps certified by comodo” and set the security level slider to the top.
Remember to restart the firewall when you have made new settings, and they don’t seem to work.

If your server is acting purely as a WWW server, then you’ll need to create a rule allowing port 80 TCP inbound (assuming you have configured your server software to use port 80). Until this rule is in place, the default rules created by CPF will block all unsolicited inbound traffic, which is what a good firewall should do (Sorry, Mr. Norton ;))

Hope this helps,
Ewen :slight_smile:

Thanks for the feedback.

And yes, my server is just a www server and is running on port 80. With Norton you only had to add the apache server (.exe) to the trusted list and select allow all inbound/outbound traffic and you’re done. I tried to do the same with CPF but I forgot the port thing hehe

I’ll give that a try when I get back home and let you guys know if it worked.

Thanks again for the help.


It worked, port 80 is now forwarded and working like a charm :slight_smile:

Great! :■■■■

Good to hear. I’ll flag this as resolved and lock the topic.

Ewen :slight_smile: