LibreOffice freezes for a minute when CIS is run

using Comodo Internet Security 6.0.264710.2708 on Windows XP sp3. I also use LibreOffice v4.0.1.2. When I use LibreOfficeCalc and click right mouse button and select Format Cells and LibreOffice freezes for one minute in Windows Task Manager there is “Not Respodning” tag beside LibreOffice Calc, but there is absolutely no activity in Task Manager - there is CPU 0% to 1% occupied by Task Manager, no other processes consumes any CPU.

But after a minute dialog LibreOffice Calc dialog is displayed just fine and I can normally work as usual. If I repeat the task then freeze for a minute again.

If I close down Comodo Internet Security (CIS) and also close down LibreOffice and restart LibreOffice and it opens dialog in a second. So there got to be something related to CIS.

In CIS in Advanced settings | Security Settings | Antivirus | Exclusions | Excluded Paths I set: C:\Program Files\LibreOffice 4.0* On Excluded applications I have set: C:\Program Files\LibreOffice 4.0\program\scalc.exe, C:\Program Files\LibreOffice 4.0\program\soffice.exe and C:\Program Files\LibreOffice 4.0\program\soffice.bin. But it looks like this does not solve the problem.

How can I set CIS to stop interfering with LibreOffice. It is very annoying to work with LibreOffice if I have to wait for minute to just continue to work.


Are you getting any any notifications from Defense+ ? Do you have Defense+ enabled? I tested this on my system and I do not have any exclusions in the Antivirus section but I do have a rule in Defense+ to allow soffice.exe to run (an executable) of soffice.bin. In my testing, right clicking on a cell (in Calc) and selecting Format Cells resulted in the dialog box opening right away.

Try adding calc.exe to the Exceptions of Detect shellcode injections and see if that helps.


I have removed all of my settings from Advanced Settings | Security Settings | Antivirus | Exclusions from both tabs Excluded Paths and Excluded Applications. So Antivirus is not a problem.

Then I have added Advanced Settings | Security Settings | Defence+ | Behaviour Blocker | Define exceptions for behaviour blocking | clicked on Exceptions link and add path C:\Program Files\LibreOffice 4.0\program\soffice.bin
and problem is solved!

Thanks a lot for help.

Thanks for coming back and telling us about the solution. This is always helpful to future users who may have the same problem. :slight_smile:

I have upgraded LibreOffice to v4.0.2.2 (so only bugfix release) on Windows XP and still using CIS 6.0.264710.2708. Now I am constantly having the same freeze problem. To test the problem I have disabled Antivirus and Behavior Blocker and still get freezes for few minutes in LibreOffice. I also disable firewall (I know this will not help), but the only think to really unfreeze LibreOffice is to shutdown CIS completely.

Any idea what could be wrong?

P.S. I have updated CIS (green Update button in GUI) and it reported that CIS is up to date.

Try adding the soffice.bin file to the Exclusions of Detect shellcode injections. I think that did the trick for its Open Office counterpart.

I SOLVED THE PROBLEM - again :slight_smile:

  1. In CIS click on Task green arrow to get into advanced settings.
  2. Advanced Tasks | Open Advanced Settings | Security Settings

3. Antivirus | Exclusions | Excluded Paths tab I set: C:\Program Files\LibreOffice 4.0*
4. On Excluded applications tab I have set: C:\Program Files\LibreOffice 4.0\program\soffice.bin

5. Defence+ | Behaviour Blocker | Define exceptions for behaviour blocking.
6. Clicked on Exceptions link and add path C:\Program Files\LibreOffice 4.0\program\soffice.bin

  1. Then I have restarted Windows. And problem solved, now dialogs in LibreOffice opens without delay. No multiple minutes dialog freeze anymore.

P.S. I haven’t added “shellcode injectionse” exception.
P.S.S. It looks to me if just disabling antivirus/defence+ when LibreOffice is running it does not make any effect so dialogs still freezing. Don’t know when this disabling settings apply, but to me it looks it does not apply immediately as expected. Maybe it applies for new processes that are not yet scanned, but for current process (like LibreOffice dialogs currently in scanning) does not apply.