Lazarus - Freepascal compiler not working correctly with Comodo installed

Read this:

It doesn’t matter whether Defense+ is enabled or disabled. Comodo simply prevents Lazarus from working correctly.

Try to uncheck “detect shellcode injections” under Defense+/Advanced/Image Execution settings. If this resolves problem add executable(s) of Lazarus to the shellcode injection exclusions.

Again: It doesn’t matter whether Defense+ is enabled or disabled.

If I can point you to another post in the same topic you linked to, another Lazarus user clearly describes how to get Lazarus working on a PC with CIS with D+ active:

P.S. Once you are past this hurdle, beware of the well known buggy debugger (is there anything worse??)LOL

Def+ level is not related to detection of shellcode injections (though it should).
Detection of shellcode injections is active even if Def+ level is “disabled”.
Al right i finished with this.

Unfortunately this cure is worse than the disease as it disables an obviously important part of Comodo’s detection engine.

For the time I am running Lazarus on a virtual machine and I expect Comodo will eventually deal with this problem. Obviously its on their end, not otherwise.

Anyway, thanks to you both for your time.