Launching cfp.exe immediately upon login

A while back I had a problem with cfp.exe taking its sweet time being launched by Windows (WinXP x64 to be precise), and since I run in Paranoid mode, if something unknown tried to run before cfp loaded, it would fail, and I would not even get prompted. Just in case anyone has the same sort of problem…

My solution was to pop open the group policy editor (gpedit.msc) and add cfp.exe as a logon script. cfp.exe was reliably launched before anything else, as it should have been in the first place. In areas where I use “Start → Run”, if you’re running Vista, you may not have the Run option in the Start dialog by default. Alternatively, you can hold the Windows logo key (Usually between Ctrl and Alt on the keyboard) and press R.

If you’re running Windows XP or Vista (I tested on 64bit, but 32bit should work no differently):

  • Start → Run
  • gpedit.msc [Enter]
  • Navigate to Local Computer Policy → User Configuration → Windows Settings → Scripts (Logon/Logoff)
  • Doubleclick on Logon in the right-hand pane
  • Click “Add”
  • Click “Browse”, and find cfp.exe (Typically C:\Program Files\COMODO\COMODO Internet Security\cfp.exe)
  • Enter “-h” in the Script Parameters box
  • Hit “OK”, then “OK”, and close the group policy editor

For both operating systems, the change is immediate, and you can test by simply logging out and logging back in.

Edit: After further testing, it seems that the launch script for Vista is not needed. :slight_smile:

As an alternative, what if you ran CIS in training mode during one bootup process to learn the applications that need to start? Would this help your issue any?

New program or hardware installation that may require a reboot and launches upon login? A perfect example would be installing a Korean or Japanese IME. If CIS takes its sweet time loading up, the IME may actually be prevented from loading.

Place CIS in training mode (Defense+ and Firewall). It will remain in this mode until you change it back after next bootup.

Unless this has changed in a recent update, to my knowledge, CIS stores all of its rules in the registry, and when any change is made, it rewrites -all- of the rules at once. After prolonged use, every prompt will bring my systems to a crawl, thus I actually make an effort -not- to run CIS in training mode.