Launch Comodo at startup [Resolved]


I recently installed the Comodo firewall and everything works fine except that it doesn’t start automatically when I turn my computer on (must be done manually) and can’t find how to fix this issue. Help anyone?

Thanks a million

Hi aquaman, welcome to the forums.

When CFP is installed it tries to create a Registry Start-Up entry in HKLM..\CurrentVersion\Run, with the default command line of…
““C:\Program Files\Comodo\Firewall\CPF.exe” /background”.
I can only assume that you have another security application running that prevented this…?

ok, so… how do I fix the problem?


The easiest way is to re-install CFP & either allow CFP to create a start-up entry when prompted by the other security app or to disable the other security app. If there is no other security app, then you’ll need to create the value manually (means using a StartUp app if you have one or RegEdit). Another way is to import a prepared REG file with the appropriate registry entry. The REG import can only work if you installed CFP to the default location or the actual install path is known in advance.

In my experience, it is advisable to shut down other active security applications prior to installing CFP; they tend to interfere behind the scenes, and even whey they offer prompts, it seems to interfere enough to corrupt the installation. Disabling the other apps before install seems to resolve a number of issues.


OK I figured it out. I manually added the instruction in the registry. For future reference in case others present the same issue, this is what I did. As always, be careful while in the registry editor…

  • Go to the Windows Start button and click on Run.
  • Type regedit and click OK.
  • Expand the list on HKEY_CURRENT_USER (click on the + sign)
  • Expand “Software”
  • Expand “Microsoft”
  • Expand “Windows”
  • Expand “CurrentVersion”
  • Click on “Run” so you see on the right side window the list of programs that run at start-up
  • Place the cursor on the right side window; right click the mouse and go to new/string value
  • Name it Comodo Firewall Pro
  • Right click on the new entry and go to Modify. If your Comodo program was installed in the default directory type in the “value data” field (quoe marks included)
    “C:\Program Files\Comodo\Firewall\CPF.exe” /background
  • If you installed Comodo somewhere else, type the appropriate path
  • Restart your computer


Thanks to all that responded.

Great, we’ll mark the thread as resolved for others’ benefit, and close it. If you need it reopened, just PM a Moderator (please include a link) and we’ll be glad to do so.