latest update prevents programs from loading

New here, forgive if I’m posting this wrong or in the wrong place. I have free CIS 5.12, Windows XP SP3. The latest update I am prompted to install (which requires a restart), seems to prevent any of my programs, browsers, etc from loading. The computer just ignores me when I try to open a program. Disabling Comodo doesn’t help. The only way I can fix it is to boot in safe mode and do a system restore to before the update was applied.

I think something definitely went wrong with the update. My advice would be to reinstall it by following the advice given in this post. Note that for your case I would advise running the removal tool in Safe mode both times.

Please let me know how reinstalling it goes.


So I followed all the instructions to the letter, and when I reinstalled the latest version, I had the SAME PROBLEM! So I had to system restore back to before I did the uninstall, but this time, since everything in the registry had been deleted, now I have to take all my programs out of the sandbox. Evidently, the latest version is the problem, not the updater itself. So I will just have to stay with the build I’m on, then? It is 5.12 something or other, but now it is not showing me the version when I click the “about.”

I am really having big problems now because now when I boot the computer I get an error message: “System settings protector has encountered a problem and needs to close.” I can no longer open my system restore to set a new restore point, I can system restore from safe mode only to a previous point, and when I tried this, it didn’t help the problem, I got the same system settings protector message. I am not sure now what I should do about this. Please tell me there is a way to fix this and that I haven’t wrecked my whole system.

Are you using Spybot with Tea Timer enabled? That may be causing the “System settings protector has encountered a problem and needs to close.” error. This may be a separate problem from the one with CIS.

Please try a clean install of CIS v5.10. If you don’t have the installer of 5.10 get it here from Filehippo: Download Comodo Internet Security 5.10.228257 for Windows - .

Page on link do notwork correctly. I try download some early versions, but before download starts file size is in all cases was 93.6 (i.e v. 5.12). :o :o :o

Sorry about that. I thought Filehippo had CIS hosted on their own server instead of linking to the Comodo servers.

I checked further and found that Filehorse actually serves 5.10: Comodo Internet Security 5.10.228257 (32-bit) Download .

I checked the file and the signature was intact; it is the real unscathed file.

Ok, I really need help. I cannot remove the comodo at all now in order to install version 5.10. I get the following error message:

The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.

I was not in safe mode. Also, when I try to open System Restore from the start menu, I get the following error message:

You do not have sufficient security privileges to restore your system. Please contact your administrator, or lougout and log in again as an administrator and try again.

I can RUN system restore from safe mode, but when I try to restore to before this whole thing started, I get the same errors, it doesn’t help. So something got messed up along the way when I tried to uninstall with the Revo the first time. Can anyone please help me? Desperate at this point.

Hi RE,
Please try running the unofficial Uninstaller Tool for Comodo Products in Windows safe mode before attemting to re-install.

From the information you have given I am not clear whether this is a bug/issue.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK.

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

I beg to differ, with all due respect, this is ABSOLUTELY a bug issue. Everything was fine on my first build of Comodo 5.12, the problem started when I tried to update to the latest build of 5.12. Even when I clean-installed the latest version, my computer did not function normally. I finally successfully used the removal tool and installed version 5.10, and it is ok. So the problem is with the latest version. Please let me know when it is “safe” to update the program. For now I will stick with 5.10.

So, it is clear to me that it IS a bug in the latest version of 5.12… The previous moderator post asked that I request it be moved back to the bug forum if that became clear… I did so, above, but have not heard a reply. Is there some formal way I have to ask a moderator to do so, rather than just asking here? BTW, it’s not for me, my issue is fixed by going back to 5.10… but I think this should be fixed, in general.

For some reason CIS is the odd one out with Filehippo, older versions of other Comodo products are available there.