Killswitch not working-CCE


I downloaded the Free Comodo Cleaning Essentials program and everything works fine, except for the Killswitch. And when I click on this icon, it first says “initializing” and then says “starting engine”, but when it starts to load up, it then quickly shuts off ?? The CCE Scanner and also the autoruns programs works fine.

I also had ran the computer in the “safe mode” and I was able to get the Killswitch to work ?? So, I decided to do a run a data base update and do “Full Scan” for my computer in “safe mode” as well, and it only found tracking cookies.Then I started up the computer in regular startup mode and again the Killswitch would not load up ??

I also am logging into my computer as the Administrator in safe and regular startup computer modes.

Could anyone help me with this problem ???

HP Pavillion laptop
windows XP Home Edition Service pack 3
1.86 Ghz AMD microprocessor
1GB Ram

Thanks for your help-Rick

Do you have any other security software on your computer?

Hi Chiron,

Thanks for replying back to me. And yes I have McAfee Internet Security Suite as my Antivirus program and Firewall protection. But, I also downloaded the CCE program on my wife’s computer, which also has the “same” McAfee AV program, and she is able to get the Killswitch to open up on her computer.

Finally, I also removed and re-installed the CCE program on my computer and the killswitch starts to load up and immediately shutoff during normal computer mode. But, the Killswitch will fully open up under “safe” mode. I also tried using other Malware scanners under safe mode, like DR web, Malabytes, Hitman Pro (Full scans) and nothing was found except tracking cookies. My wife also has these “same” Malware scanners installed on her computer.

Thanks Rick

Is it able to open if you hold down the shift-key? To test this first hold down the shift-key. Then, while still holding down the shift-key, open executable for KillSwitch. Only let go of the shift-key once KillSwitch is fully open.

Does that allow it to open?

Hi Chiron,

I tried and did “exactly” as you had instructed me to do, but it still did not work. My desktop icons and task bar had disappeared after I did what you had told me to do. And I could only shut down my computer by using the task manager, by pressing the Alt-Control-Delete buttons. When I restarted computer, all my desktop icons and task manager had came back.


Okay, I’m not sure what else to try. This may be a bug.

However, can you try completely disabling McAfee and see if you can then open KillSwitch? It’s worth a try.



I will try your suggestion and get back to you soon.

Thanks Rick

Hi Chiron,

I completely removed the McAfee Internet Secuity and its Firewall. I also installed the Comodo Internet Security and Firewall. Again, everything work “Great”, except for the Killswitch, which still starts to load up and shuts off. Again, I also ran "Full Scans in safe mode and with its updated data definition bases, for the following programs: Malwarebytes, Dr Web Cure It, Rkill, TDsskiller, Superantispyware, and HitmanPro. And everything is good and clean.

Is it possible that I have a bad or corrupted registry key entry in the windows system ? And is there anything I could look for and fix in the registry ?

Thanks Rick

I’m not sure. Hopefully someone else will have some ideas.


What happens when you go to advance settings in Comodo Internet Security and launch kill switch from there?
See Attached Screenshot. It may make a difference i don’t know it’s worth a shot.

[attachment deleted by admin]

Hi DrHaze,

I went under Advanced Tasks and then opened up Clean Endpoint, where I found Comodo Cleaning Essential tools. There I found Killswitch and tried opening it up. It starts to launch program, but quickly turns off ?? Everything else works great, including the Autoruns program.

I am also logged into my computer as the Computer Administrator.

Thanks for your suggestion and help-Rick

I open killswitch to get to the autorun program.
How do you get to the autorun outside of killswitch?
See Screenshot Attached…

[attachment deleted by admin]

HI again DrHaze,

The AutoRun Analyzer program is under the Tools section of the Comodo Cleaning Essential program that is in the Clean Endpoint Task, which also has a separate program for Killswitch.

Thanks Rick

Hello Chiron and DrHaze,

Just to let you know that I finally was able to “Fix” my problem with Killswitch not working. I had typed in “msconfig” in the RUN command and went to the System Configuration Utility menu. Then after much trial and error, I has able to figure out which Microsoft Services was causing the Killswitch program from not starting up. It was the service named “Simple TCP/IP Services”, which I had unchecked. Now, the Killswitch will start up and run, showing all the applications that is running on my computer.

Thanks Rick

What operating system are you running?
Glad to see it working.

Hello I don’t mean to hijack a thread but I am also having the same problem with KillSwitch. I use only Comodo Firewall I have downloaded KillSwitch through the Firewall. I downloaded CCE and KillSwitch does not work on there either. When looking at the task manager it goes to load up but shuts back down after a couple seconds.
I search my reg and found
In them it has KsAppData, but for the data it is empty. Should there be a data value in the data field for the reg files?

I can scan my computer with CCE, and I can also use autorun. My computer has no virus well at least are being reported. I am using vista 32 home prem. And I have 2013 AVM from stopzilla(which when turning off still creates the same problem)

Sorry once again for hijacking…

Hi DrHaze,

My OS is Windows XP Home Edition with SP3. Again, everything in Comodo Internet Security works perfectly.

Thanks Rick

Hi saywhy,

I also had this problem and was able to fix it. Please try to run your computer in “Safe” mode and then open up your CCE program and try to run Killswitch under the tools section. If you are able to run the Killswitch under the “Safe” mode, then you will be able to run it under “Normal” computer mode. Please read this entire thread and you will see what I did to fix this problem with my computer.


le 11/12/2013

Pour essayer de faire fonctionner COMODO “Killswitch”
avec Windows XP SP3, COMODO 6.3.302093.2976, Kav 2013, puis KAV 2014

1 ) - Vérifiez que la tâche “Killswitch” n’est pas “non ouverte” mais restée active dans le “Gestionnaire des tâches de Windows”
Avec “Ctrl+Alt+Supp”, tuez cette tâche en la sélectionnant et en cliquant sur “tuer le processus”
si elle est active.

2 ) - Conseil de désactiver le “Service TCP/IP simplifié” : “tcpsvcs.exe”, comme déjà indiqué dans le post de rsh4810 N° 13 ci-dessus…

3 ) - Si vous utiliser aussi le logiciel VMWARE :

  • conseil de désactiver le “Service VMware USB Arbitration Service” : “vmware-usbarbitrator.exe”
  • conseil de désactiver le “Service VMware Workstation Server” : “vmware-hostd.exe -u”

4 ) essayer de désactiver temporairement Kaspersky 2013 ou 2014 ou les fermer complètement (Kaspersky 2014)

5 ) désinstaller supercopier ou ultracopier (ceux avec le soft intégré CGMINER) et utiliser les logiciels équivallents sans Cgminer …
CGMINER est un moyen pour le développeur de rentabiliser financièrement son soft en utilisant le Gpu de votre carte graphique pour éxécuter des calculs; ce faisant, sans trop vous l’expliquer clairement, cela ressemble à de l’Aware ou soft plubicitaire.

5 ) essayer à nouveau de lancer “Killswitch”

Sinon, en attendant que “Killswitch” fonctionne je vous conseille d’utiliser :
-Process Explorer ou Autoruns de Sysinternals
-Osam autorun manager 5 (portable)

Pour faire fonctionner COMODO Kiosque,

  • Fermer l’application “Sysmétrix v3.45”, si vous l’utilisez.

Joey, could you please translate your post into English?