Kaspesky Update (kavsvc.exe) blocked by Comodo

I have been having problems with Comodo Personal Firewall in that it says Kaspersky Anti-virus (version 5) refuses to communicate with it. I was wondering if you had any information regarding this?

Irritatingly, you can’t “Always Allow” on this pop-up…




You could try turning off “Allow invisible connection attempts” and “Skip advanced security checks” in the MISCELLANEOUS properties of the Application Monitor rule for this app.

There is actually a design reason why “Always Allow” isn’t available for this type of warning. Applications refusing communications with another running app is a highly unusual cimcumstance and can indicate the presence of a rootkit. As such, every occurence needs to looked into.

Hope this helps,
Ewen :slight_smile:


Thanks for reply. I’ve already tried that but to no avail. also tried re-starting just in case…



I was planning on starting a new thread, but decided to do a search first, to see if my issue had already been addressed.
Having found it posed, precisely the way I would have stated it, this thread unfortunately appears abandoned, prior to having reached a conclusive solution.