Javaws.exe may not run properly, even though trusted by D+ AV & FW [275]

while having CIS installed it is very difficult to get this .jnpl to run without getting the java web start error message “splash: recv failed.”

the particular java application i am attempting to run can be located here:

i have made numerous additions to the firewall and defense policies. i have even disabled all functions (AV, FW, D+) of CIS without much if any increase in success rates. i also tried “exiting” CIS which does increase application start success rates marginally.

in fact, the only way i have been able to get the java application to run without fail is after uninstalling CIS.

i am open to suggestions or work around methods other than those which i have found via searching “splash: recv failed comodo” as none of those have been successful in the least.

This is a huge issue. I finally uninstalled comodo so that I could open a simple java app. Now I just reinstalled b/c i do not want to be without the protection and hoping it would magically be fixed, but of course it’s not. Is there any fit for this? Is it even acknowledged that there is a problem? I see there’s a forum post about this from months ago without resolution. Please help.

Edit: For instance, if I try to open the link several times (10+ times) “Enter The Gathering Place to play this game” found at it will usually work eventually. So Comodo doesn’t always block it, but it usually does. So there’s got to be some bug. It should either always block it or not and we should be able to make it a trusted app and never have a problem again, right?

Hi i am trying to create a batch file, which will

  • open the java web start application
  • Input my username and password automatically
  • succesfully connect to wireless network

I have looked at some other code and tried to ammend it to my situation so far i have managed it to open the java web start app.
the code i have is as follows

@echo off
ver > info.txt
ipconfig /all >> info.txt
wireless.jnlp -s:commands.bat

Start wireless.jnlp

  • my username
  • my password
    cd public_html
    put info.txt

If anyone has any suggestions for help please let me know… :slight_smile:

unfortunately, i was forced to change to a new security suite.

i hope this problem is corrected at some point.

Same problem here. Still getting this error:

Splash: recv failed

when trying to start .jnlp application. Nothing has helped so far… (Adding javaws.exe to trusted applications etc.)

Sometimes I have to launch the .jnlp app 4- or more times to get it working. Really annoying! ???

Vista 32bit, CIS 3.8.65951.477

Me too :(. I hate to say it but it looks like I’m going back to ZoneAlarm.

Can you tell or show us the what is in the logs when you start the game? It is working here with jre 1.6u13 on Win 7 with 3.9 beta (491).

Delete all references to Java in D+ → Advanced → Computer Security Policy. Then make Sun a trusted Software vendor and make all .exe and .bat files in the Java folders part of My Own Safe Files

I also have the exact problem being unable to run Java Web Start apps. I also get the splash screen error.
I have tried changing every setting in Comodo and I don’t use D+. Sun is marked as a trusted vendor, even entire Java directory is marked as my safe files. There is no sign in any of the normal firewall event logs of Java Web Start being blocked but still it doesn’t work.
I run Win XP SP3 with JRE 1.6u13.
If I uninstall Comodo it works fine.

Is it possible to turn on some other (hidden?) more technical log?

I really hope for a solution very soon or I am forced to move away from Comodo to something that works.


Has anyone found a solution for this? I too have added sun and jave to every allowed list in Comodo. However, the only way it works is to uninstall Comodo. Like the others there is nothing in a log to suggeste javaws.exe is being blocked.

Tuesday v3.9 will be released. You could try this version. Or if you don’t want to wait you can download the v3.9 RC2: .

When using the RC2 there is a program update waiting that gets installed in two steps. The first step is an update simulation testing updating from 3.8 to 3.9. The second step is the real program update.

I have the same problem, and I fixed it for now by changing to a different firewall, still running Comodo av and D+.

I did try different settings for days on end, and finally gave up. I do hope that this will be fixed soon. I have to use programs based on java, so I can’t use the Comodo firewall in Vista until it’s fixed.

I am having the same problems with Comodo 3.10 on XP.

Hi Guys

Please post your bugs here:


From a previous post about the problem residing in the firewall, I figured out how to make webstart run on my machine (Windows Vista Business)

D+ Settings are still at “safe mode”, but I set the Network Securith Policy in the advanced section of the firewall to treat C:\Program Files\Java\jdk1.6.0_07\jre\bin\javaws.exe as a web browser.

This seems to have cured the problem after I tried most of the above suggestions so it may be a combination of them all.

Hope this helps.

Same problem. Still getting this error:

Splash: recv failed

Most annoying is that this happens randomly. May be this is a bug?

Vista 32 bit.
CIS 3.10.102363.531

I think, it’s a browser/comodo related problem.
I’m uising mostly Firefox, and after recieveing this error multiple times (google books uploader), i started Opera and it worked ok.

Maybe you need to add firefox as a trusted application or something like that

I am having this problem with XP 64bit and comodo 3.12.111745.560. I have tried many things but none work. About 10% of the time I can load the java. What is the deal. I would have thought this to have been fixed by now. I am trying to run the jnlp directly from my desktop.

I was having this problem too. I could get one javaws application to work but others would give the same error message. As there are 32 and 64 bit binaries for javaws and various libraries I was thinking that perhaps the firewall is getting confused so I had a mess around and found a way to get all working.

The fix was to remove “sun microsystems” from the my trusted software vendors. Then to remove all entries referring to javaws.exe in Firewall Network Security (Application rules) list. After doing that setting the defence and firewall mode to “safe mode” (not training) then open up a java web start (javaws.exe) application and when the firewall popup appears select “allow” and tick the remember tick box. This should only need doing once and after that all javaws applications should work without the error.

Hope that helps someone. I still think Comodo need to look into testing this more thoroughly as there seems to be some sort of conflict when running multiple javaws apps when running Comodo.


This is a workaround solution. I do not know if disabling the splash screen is a security threat but this worked for me.

Instead of creating a link for each java application, you could add the -Xnosplash to all jnlp executions.

Open Windows Explorer, go to Tools → Folder Options → File Types tab
Select the JNLP extension from the list, highlight it and click Advanced
Highlight Launch and click on Edit

On the 2nd line you add the -Xnosplash between the application path (javaws.exe) and the jnlp file selector (%1)

On my PC I replaced “C:\Program Files\Java\jre6\bin\javaws.exe” “%1″

with this line:

“C:\Program Files\Java\jre6\bin\javaws.exe” -Xnosplash “%1″

Now all jnlp executions bypass the splash screen.

Hope this helps.

This problem is really serious!
The “Xnosplash” method does not work everytime.
I hope COMODO will fix it in the next version.