Java has been blocked by my security settings

I received an update from java on my Win7 laptop while playing on Yahoo games, and after installing the latest java I can’t enter any rooms as it gives an error that my security settings has blocked it. I only have CIS as my security program on my laptop and I wanted to ask if CIS has blocked it, and if so how can I solve this issue.
I hope I have posted this thread in a right forum.

Try downloading this - JavaRa 2.0 Alpha Build Available - SingularLabs

First try updating Runtime if that does not work then remove JRE completely then check program & features in the control panel for anything Java related if anything is found also uninstall.

after that do a fresh install from

Good Luck

Thanks for the reply.
I did the whole you mentioned but it didn’t help. I even tried entering games sites with other browsers and it still blocks, what else can I do?

I only have CIS as my security program on my laptop and I wanted to ask if CIS has blocked it, and if so how can I solve this issue.
Look. Whether is in the blocked. Probably there were records. Remove records.

Thanks jenny for the reply,
I looked in that section you mentioned but there are no blocked files.

Hey simon101,
You said you recently updated Java. Do you have anything running in the Auto-Sandbox. Maybe a certain part of java such as deploy.jar is being isolated due to the fact it has not been white listed by Comodo yet. Try Disabling the sandbox and see what happens. If that does work totally exit CIS then see what the result is.

I both disabled the Auto Sandbox, and also tried closing the entire CIS to see if the Java runs again, but it didn’t help.
It is not help?

The only other thing I can think of is going to the Windows control panel and opening the Java control panel and experimenting with and reducing the security settings and permissions.

Good Luck

So after you disabled CIS do your Java applet run, but still give a security-setting warning and not function?
What’s that message exactly?

Maybe it’s a security measure built into Java or your web browser - Java in web browsers has been a ad source of security problems over the last couple years and lots of companies have been trying to help out by adding oddball pieces of security here and there. I think MacOS started disabling Java in Safari by default and if you enable it and then go a couple weeks w/o using it, it auto-disables again. And the VM I use when I have to use scripting heavy websites has a copy of Java on it that the web browser refuses to run b/c it has known security problems.

This also happens when running the Firefox browser in Windows.
It does not apply to javascript, it applies to JRE (Java Runtime Environment) which can be a Firefox plugin. The browser used to allow this plugin. Recently it has been disabling it by default, and Firefox shows a message saying that Java is a security danger.

So… are you sure it is being blocked by CIS and not by your browser?