Issue running Kaspersky Anti Virus, Comodo Firewall, & Sandboxie, w/ Vista&7 64

Greetings, :slight_smile:

I am writing to report a very frustrating and confounding three way interaction issue between Kaspersky Anti Virus, Comodo Firewall version 4 and up, and Sandboxie, that had me at my wits end for a few months before, after much hard work doing painstaking troubleshooting, I finally discovered the solution.

It appears that when the three are installed together (at least under Windows Vista and Windows 7 64 bit editions), that Firefox, when loaded in a Sandbox, upon loading, hangs for ages before it loads properly. If I had to make a rough guesstimate of the time it takes to load, I would say anywhere from 3-4 minutes. That’s an astronomical amount of time, considering the speed of my system. I have an MSI K9A2 Platinum motherboard running with an AMD Phenom II Quad Core 3 GHz processor, 8 GB of A-DATA 800MHz DDR2 memory, and a Western Digital 500GB 7200 rpm hard drive.


The problem occurs in this exact configuration (Configuration A):
Kaspersky Anti Virus 2010 version running under Windows Vista 64 bit
Comodo Firewall only (no proactive Defense+) versions 4 and up 64 bit under Windows Vista 64 bit
Both Sandboxie 3.46 64 bit and Sandboxie 3.48 64 bit under Windows Vista 64 bit

Under the above configuration (Configuration A), I went as far as disabling almost every single one of the features of Comodo Firewall, all together, at the same time. Firewall completely disabled, most every feature that could possibly interfere, and many that couldn’t possibly interfere, disabled. No joy. ???

I also tried completely disabling the Kaspersky Antivirus, without uninstalling it. No joy :frowning:

I also tried removing my custom Firefox configuration from Sandboxie, and enabling access to the entire Firefox profile folder, using the Preset Application Configuration designed for that. I also tried moving Firefox from my Firefox sandbox to my Default sandbox. I also tried just about every possible configuration change in the Default Box, and in Sandboxie as a whole, short of reducing the security level significantly. No joy ???

The problem occurs in the following exact configuration (Configuration B) as well:
Kaspersky Anti Virus 2011 version running under Windows 7 64 bit.
Comodo Firewall only (no proactive Defense+) version 4.1.150349.920 64 bit under Windows 7 64 bit.
Sandboxie 3.46 64 bit under Windows 7 64 bit.

I didn’t hash out the same battle with Configuration B. I ended up finding a different solution, finally.

The issue DOES NOT occur in the following exact configuration (Configuration X):
Kaspersky Anti Virus 2010 version running under Windows Vista 64 bit
Comodo Firewall only (no proactive Defense+) version 3.14.130099.587 64 bit under Windows Vista 64 bit
Sandboxie 3.46 64 bit running under Windows Vista 64 bit.


The solution is:
Disable the Kaspersky URL Advisor extension in Firefox. :slight_smile:

Yes, it’s really that simple. :-TU

Regards, ;D

Welcome to the Forum, ferenc.

Thank you for this detailed report.
I hope others find it quite useful also.

Congrats on finding it and your tenacity.

Technically speaking not Comodo bug. Moved.

Greetings all!

Hi ferenc,
Thanks for the report indeed

That could be “technically speaking” Comodo’s v4 issue, since the following remark:

I don’t have any issues running v3 of firewall in Proactive & with defense+ on win 7 x64 … but there are too many issues with V4 - even having sandbox disabled
therefore still using v3


Wow… :o I really admire you, SiberLynx. You really wanted to know, didn’t you? Hm. Yes, I agree. It must have been a comodo 4 bug.

But the supposed solution was

If it were true that you completely disabled Kaspersky before, then I suppose that URL Advisor was turned off, too. But to no avail, correct?

But that solution worked for v3. Therefore, the only logical explanation would have been that it was a comodo 4 bug. Other than downgrading comodo, the only difference i see is in sandboxie (only one is running. on the first config, you were running two, correct?), but i highly doubt that would have caused the problem.

This should be in the bugs section in CIS.