Issue Installing VPN TAP Adapter


I have noticed that for a while I have had an issue with the VPN Tap Adapter for ProtonVPN as it fails to install with CIS installed.

There is also no mention of it being blocked in the CIS logs.

PortonVPN is free. Could someone please test and see if they have the same issue?

P.s. Also does not install with HIPS and Auto-Containment disabled.

Kind regards,


I can’t vouch for ProtonVPN, but neither Mullvad nor Surfshark will install with CIS running, due to the Tap Adaptor issue. Mullvad has a warning on its site that CIS should be disabled, but I’ve never found a way to do that successfully, that allows the installs to complete

Now I just export ‘everything’, uninstall CIS . . . install Surfshark and/or Mullvad new versions and then reinstall CIS. A little fiddly, but I’m used to it now

Ah, thank you Ploget!

The OpenVPN TAP adapter has problems installing when CIS is installed.

This occurs even when HIPS and Auto-Containment is disabled.

[i]As per:[/i]

Kind regards,


Just to be clear has this only started happening with the 12.2 build while older ones had no issues? Seems to be related to this issue with creating the hyper-v ethernet adapter. I merged your other topic into this one as it does appear to be a bug with installing new network adapters when CIS is installed.

Yeah, I’ve only noticed this issue with

Hello ReeceN,

Thank you for reporting.We will check this issue and update you.
Have a nice day :slight_smile:

First time I noticed it was April last year, when I installed Mullvad and it’s been the same ever since through all their update versions. Surfshark was the exactly the same and that was November. Wasn’t prepared to start disabling and altering various CIS settings to void the protection I had, so just uninstalled and reinstalled offline to get everything working well together

I had a similar experience recently with ExpressVPN. Something wasn’t quite right. The network connection icon in the notification area would sometimes show as a WiFi icon (what my PC is using) and sometimes an Ethernet icon (I assume installed by the TAP adapter). Additionally, there were 2 networks, 1. my own local network and 2. the new ExpressVPN network. BOTH were showing internet access. In contrast, on my wife’s laptop PC with only Windows 10 security software, hers only showed an Ethernet icon and only the ExpressVPN network had internet access. The local network had none.

Armed with those observations and a couple chats with ExpressVPN customer service, I determined that the wife’s PC showed the correct VPN behavior. What I did was uninstall Comodo CIS (normal uninstall), then uninstall the VPN. Reinstall the VPN, allowing Windows security to take over with it’s annoying notifications (in my case). I first tested the VPN to determine all was well before I reinstalled Comodo CIS.

The next day during the process of auditioning several webcam apps, installing and uninstalling, during one of the reboots, Comodo CIS flagged 2 of ExpressVPNs files. I don’t know why it did at that time, but I whitelisted them both and haven’t had any issues since.

Also make sure to thoroughly test the VPN. Apparently not all are created equal and some will for instance allow WebRTC leaks. You can turn off WebRTC in Firefox but not Chrome based browsers. Chrome only allows extensions to deal with this issue, which I’ve heard may not be reliable.

Hello CommodoUser2019,

I had reported to the corresponding team members and they are checking in it.Further any info I will notify.

I’m just now seeing this, and it explains a LOT!

I recently had two massive hardware upgrades, both times, resulted in a fresh install of Windows.

after the first upgrade, I attempted to install TAP network adapters via multiple programs:
OpenVPN (directly)

None of these worked, and were completely blocked. Device manager showed them as there, but with ! next to them, stating it was waiting for something to complete. Can’t remember what it was waiting on now, but I thought the problem had been with one of the hardware upgrades.

After the second upgrade, I installed IPVanish, before installing Comodo. The TAP adapter installed flawlessly, and is still working with Comodo installed after.

No security solution should be blocking any non-malicious drivers/devices installed from reputable sources, unless it provides a notification, and the ability to unblock it.

I honestly never associated this problem with Comodo, until I saw this post.

It’s true for a lot of VPN TAP Adapters. Mullvad and Surfshark in fact both warn that CIS has to be disabled for their installations. I’m so used to it now, that on every upgrade of their VPN software, I just export the CIS Config and File List, uninstall CIS and upgrade / install the VPN(s) and reinstall CIS

Only takes a few more minutes now, but cost a lot of time initially trying everything else!. The same is true for Proton VPN by the way

If I have to uninstall my security software in order to install something I know is safe, and is used for another type of security, then it really defeats the purpose of having any security software.

It’s supposed to keep you safe from malicious content, not content that is verified as safe, and from paid services, like IPVanish. The worst part is that Comodo doesn’t notify you, doesn’t show it as blocked anywhere in the UI/logs, (that I’ve noticed), and provides no option to unblock it. (I peruse the blocked apps/files list kinda often)

You can do the VPN installs offline in you want, but with a Router FW, I don’t feel it’s much of a problem for the extra 5 minutes or so. All those VPN(s) are whitelisted, but CIS just refuses to allow the virtual TAP Adapter install w/o any blocking or logging

After my experiences in reply #8 of this thread, I had more files being blocked by CIS. I had to whitelist the whole VPN install folder and so far no more red flags since then. I also do normal VPN software updates without disabling any security software.

The problem with more ‘complex’ VPN such as Mullvad and Surfshark, is that on their updates, they automatically uninstall then reinstall which causes the problems it seems

Please check with still blocks Protonvpn installing.

Hmm I actually tried both Protonvpn and OpenVPN and they both install just fine with this build.

Can you check if the TAP Adapter is installed and the new Network Adapter is showing?