Is CUMON.SYS part of CPM?

Is the file CUMON.SYS part of Comodo Programs Manager?

If it is, then someone around here should be interested to know that after installing CPM on 32-bit Vista SP-2, I got a BSOD on reboot with an error message telling me that “a part of the driver CUMON.SYS mistakenly marked a part of its image pagable instead of non-pagable” and I was forced to go back to a previous restore point to get the system working again.

The problem is that I installed two or three things at the same time, and so I’m trying to figure out if CUMON.SYS was part of one of the others rather than part of CPM. The problem is that I don’t want to re-install CPM to find out. So I’m asking here.


Yes, cumon.sys is a critical part of the monitoring system of CPM.

If you could send us the programs you tried to install at the same time we will try to reproduce and fix the issue as soon as possible. If you used a specific order of install that too will be useful (even though it was simultaneous).

Please post this bug here with full details so we can identify the problem.

Thank you for your support,


I’m new here and I have a big problem. After installing CPM my computer only starts with Win XP Blue Screen saying that booting is stopped caused by cumon.sys. It is not possible to start the computer again neither in safe nor in some other mode. What can I do? Is it possible to uninstall CPM or merely cumon.sys via DOS-Mode or in any other way? Need urgent help!!!

Many thanks in advance.


Can’t you really boot on “Last known good configuration” (press F8 while booting)?

Hmm. So, then, it’s not just me: CUMON.SYS really is a problem, somehow. And peumba’s posting clearly shows that it doesn’t just happon on Vista (it apparently happens on XP, too).

So, then, it sounds like a bona fide bug; and based on the BSOD error message that I got, it has to do with paging (either how it’s paging from RAM, or the paging file itself… or both).

Hello HarpGuy,

no I tried everything in the extended boot menu. I found an old “emergency-cd” from computerbild in germany which is linux based. Now I can see the whole content of my computer and can search for the problem in the web but I do*nt know how to uninstall CPM or even delete this cumon.sys via linux and I can’t find more links quoting this problem. I think someone from Comodo should give us help. Has someone tried to get help via direct contact to Comodo?

I’m no such expert. Need really help.


If you cannot boot with none of the menu options listed there, when pressing F8, you can use Windows Recovery Console from the Windows XP installation CD, to delete the cumon.sys driver. Please peform the following actions:

  1. Insert the Windows XP CD into your CD drive and restart your computer. If you are prompted, select any options required to start (boot) from the CD.
  2. When the text-based part of Setup begins, follow the prompts. Select the repair or recover option by pressing R.
  3. When you are prompted, type the Administrator password.
  4. At the command prompt, you can type the following Recovery Console commands to delete cumon.sys driver:

use ‘cd’ command to reach ‘%windows%\system32\drivers’ path
use ‘del’ command to delete the cumon.sys driver.

When you are done use ‘exit’ command to exit Windows Recovery Console and to restart the computer

At any time, you can type Help for a list of available commands.
At any time, you can type Help commandname for help on a specific command.

Another method will be to find a working hard drive and slave your current hard drive to the working drive so you can delete the cumon.sys file.

Sorry for the problem caused. If you need any more help please contact me.

Thank you

Hi ,
You can open ‘%windows%\system32\drivers’ path and delete cumon.sys driver.

Thank you

Hello Alexandru Andrei,

Thank you so much for your kind help. I’ll try the described way. But by the way, will all my other files and programs be kept and have no damage trying this way? Then this would be the solution of this problem.

Thank you once again. I’ll keep you informed if it works.


This method is safe and you will be able to boot you system without a problem.
Thank you

Hi Alexandru,

Thank you once again for your very competent help!!! Everything now works well again! Since I am using some of Comodo’s programs (Vengine, BOD, Memory Firewall) since several years without any problems I was very astonished about this.

Thank you that you saved my weekend! :wink:

Many greetings.


Alexandru wrote to peumba: This method is safe and you will be able to boot you system without a problem.

HarpGuy now adds: Then be sure to uninstall CPM as soon as you’ve successfully rebooted back into Windows.


Thanks also to you!!! So I did, I completely uninstalled CPM and now everything works as before. :smiley:


Any constructive criticism is appreciated and taken into consideration. Feel free to state your issue. There is no need for any misused irony.


See, this is why I hate posting around this place. The COMODO apologists are so ready for criticism that they see it even when it’s not there.

I wasn’t engaging in either irony OR criticism. I was simply recommending to the guy that once he got the CUMON.SYS file manually deleted so that he could reboot again, he needed to go ahead and get CPM uninstalled.

With CUMON.SYS removed, CPM was damaged and unusable anyway; and CPM was clearly not going to work out for him in any case… not until whatever’s wrong with CUMON.SYS is fixed by the programmers and there’s a new release of CPM.

There’s no irony, or even criticism in any of that… just fact.

And it’s not within your purview to try to control either my message, or the means by which I deliver it, regardless.

Shame on you. What… are you the decorum police? Knock it off, newbie! We all have a voice, here.

Sorry Dorin. Seems a valid and necessary thing to do right now. HarpGuy is right: the user must uninstall CPM and not only delete the .sys file.

CUMON.SYS is causing me all kinds of issues. It is at the point regardless of what I am doing I get the BSD relating to CUMON.SYS. I just recently created a new user account on my Win 7 Home system. After creating it and trying to log into it I keep getting the CUMON.SYS BSD screen. Other issues that have occured since installing Programs Manager is internet connectivity, firewall disabled, and other programs which I will list when I come across them again.

Now that I think about it I got the CUMON.SYS BSD when trying to even upgrade Progam Manager.

I am also using the Windows 7 Home x64 edition


I also have encountered a BSOD with cumon.sys (on a Windows Vista 32bit). Actually the BSOD was only visible for 0.2 seconds (I had to film it and pause the video to be able to read the error). I could not boot in normal mode, safe mode or even last known good configuration. I booted into miniWindowsXP using Hiren’s BootCD and renamed cumon.sys to and now I am here posting this message after uninstalling CPM.

I also have CPM installed and runing on another Vista 32bit computer, a Win7 64bit and a XP computer and they all work perfectly.

I did notice that I usually have problems on this computer CPM and also Comodo System Cleaner, both giving me a BSOD on startup. Could the reason for the BSOD be that this computer is using a Raid 0 setup?

Too bad I had to remove CPM on this computer as I really like it. I rather not go back to Revo now that I have seen CPM (when it’s stable).

Can you please tell me what version of CPM were you using?
Thank you.