Is cComodo firewall blocking access to shell32.dll

I have had Comodo Firewall installed, from an Internet download, for a few months. The Serial Number of my installed product is 605ACF34AB404cf1B03495E669007E0A. I can find nothing that tells me if is version V2 or V3.

I am running (fully updated) Windows XP Pro. Today I went to delete an installed program via Windows’ Control Panel. Clicking ‘Add/Remove Software’ (and most other Control Panel items) produce a Microsoft warning “Error loading M:\WINDOWS\system32\shell32.dll. Access is denied”. This response it is new. I have no specific data but I believe that this phenomena was not observed previously while Comodo Firewall was installed.

A Google search finds a number on ‘not entirely confidence inspiring’ entries that claim unistalling Comodo Firewall will cure the problem.

Are these Google entries correct? Is there a ‘fix’ within Comodo that will correct a problem, if there is indeed aproblem? (Searching through Comodo’s FAQs does not any mention of this problem.)

Try making it a Safe file in CFP.

Thanks Jeremy,

Before I got back to the Comodo Forum, I ran another Google search and found an older (Oct. 29, 2008) Comodo Forum response “Comodo blocks rundll32 (shell32.dll)”. It advised setting the Predefined Policy to "Limited Acess’. That worked.