ipad 2 cannot connect to vpn at the public library

:o I go to the public library often and it has wifi and I tried connecting with etrust from my Ipad 2 the VPN could not connect. I followed the instructions to set it up, but it still would not connect. I tried verify the settings by connecting via my laptop and it did connect. I then disconnected from my laptop and I tried connecting only through my Ipad 2 but could not connect.

I used the following setup:

server: uk2.vpn.comodo.com
PPTP is chosen
Send all traffic is set to on
Password provided by Comodo Etrust was used and Username

But the Ipad 2 was disconnecting the connection.

Any suggestings why the ipad 2 would not connect. It was connecting by wifi but the VPN option would not.

Odd think is when I am at home using my wifi, I can connect VPN but not at the library. Any suggestions why this is happening. I downloaded Etrust for the library specifically. Thanks for your reponse and assistance

Hi There!
I go through you post and come to know that are getting the problem of connecting your i phone with internet through VPN. Did you contact to your vpn service provider may be there is a problem from there end.
please contact onces and check. if not working still.