my ip address keeps changing and then i can’t connect to the internet

Greetings blw,

Do you think you could include some more information?
Does this occur evertyime you use your computer?
And does Internet work if you disable CPF?
Does svchost.exe got access to Internet thru ports 53,67,68,80 and 443?
If not, create this rule in application monitor:
Application: %windir%\system32\svchost.exe
Parent: %windir%\system32\services.exe
Protocol: TCP/UDP
Direction: In/out
Ports: 53,67,68,80,443

%windir% is location of your Windows folder.
Also add port 123 if you’re using Windows time synchronize.


Thanks for your help.
Yes, it was happening everytime I connected to the internet, (after Windows automatic updates) about a week ago.
Yes, the internet works when I disable CPF.
I don’t know the answer to does swchost.exe have access to Internet thru ports 53,67,68,80, and 443.
I don’t understand the rest or how to create a rule (from your post)

Note: I unistalled CPF and reinstalled it. I still have the same problem after that. I have to disable CPF to use the internet.


I think I figured out how to make an application rule.