ip add prob [SOLVED]

net is working fine but i am getting ip add 169.254.x.x i tried to release and renew but renew gives error.
i tried connecting the external lan card to another slot, enable and disable but nothing worked. any help??


Hi naren,

Sounds strange, you say the net working fine but you get a 169.254 (APIPA) address.
This normally happens when your network adapter is unable to receive an IP address from a DHCP server.

Can you tell a bit more about your network setup, and what device gives out the IP addresses?

Have you tried to reset that (power off/on) and then reboot your pc to see if that solves the issue?

Anything else you changed before this started to happen (e.g. stealth ports wizard?)

Thanxx replying Ronny. Here’s all the info i can give

WinXP SP3 (Latest Updates)
Comodo Firewall (Firewall Only Installation)
Avast 5 Free (Default Settings)

Comodo detects New Network Found 169.254.x.x
I checked with ipconfig /all and same IP 169.254.x.x

Uninstalled Comodo Firewall and Avast and checked, same IP.

Restored Windows Firewall to Default, Enabled/Disabled Windows Firewall, same IP.

Enabled/Disabled LAN Card (I have External External LAN Card), Tried connecting the LAN Card to other slots, Tried ipconfig /release and ipconfig /renew, renew gives error, Tried LAN card right click repair - gives error could not renew the IP, tried direct power off/on.

Cleaned the system with CSC and Ccleaner, deleted all the restore points, scanned with Avast, Malwarebytes, CAV, Hitmanpro and Comodo Cloud Scanner - didn’t find anything malicious, same IP.

I sometimes use router when i have to share the connection with my bro. I dont use router always coz with router the net gets slow and it also gives page cannot be displayed. But when I use router, everything is fine.

Event Viewer - Security - Failure Audit - Event ID 615 - IPSec Services: IPSec Services failed to get the complete list of network interfaces on the machine. This can be a potential security hazard to the machine since some of the network interfaces may not get the protection as desired by the applied IPSec filters. Please run IPSec monitor snap-in to further diagnose the problem.

The strange thing is that with this IP, net is working fine. Any help buddy??


So you have two connections?

One connection to the internet that’s functioning?

And a network connection LAN that you use sometimes and that has a 169 address now?
I think if you power on the router, reboot your computer it will give you an other IP address on that interface. Depending on the “lease time” the DHCP of the router gives the IP is valid for that time.

If you don’t wish CIS to alert you for this, please go to More, Preferences, and uncheck “automatically detect new networks”.

No, I have only 1 Connection. The systems LAN card has damaged so I use External LAN card.
How can i get IP 192.168.x.x which i use to get. Any help to solve the prob. No Home Network, only single laptop directly connected to net. Have a icon of my net connection on desktop which i have to click and put the user name and password and click connect to get the net working.


I’m confused, where does that cable from your external network card go to? What’s on the other end of it?

Ok. I am on the 4th floor of the building. There’s a box related to internet in the terrace of the building. Every connection in this building is linked from that box. So I too have my net connection i.e the wire through the window and that wire has a pin in the end which i attach to the back of the external lan card and attach the lan card to the usb port.


Then if I assume you network card is setup to receive it’s IP address “automatically” the problem should be with “that box” but based on your post that you have a functioning network connection I’m assuming this box is using what they call “Proxy ARP” so it help you out also on your 169.254 address (basically listens to every traffic that get’s thrown against it.

Can you ask other people if they are having similar issues if they issue an “ipconfig /release” and “ipconfig /renew” in that case “that box” is having trouble providing addresses over DHCP.

Ok I asked other people they are not having any issues.

2 days before a strange thing happened so just letting you know. As I said in my post I connect to the internet by login i.e username and password. 2 days before I was not logged in but was able to connect to the net. only difference was that anything I tried to download was downloading at 2kbps speed. I opened GRC ShieldsUp the IP add and the service provider name was different than what i get when I connect to the net. After half an hour that connection got disconnected i.e I wasn’t able to connect to the net. So I connected to my net. Just thought this may be the prob so shared it.

I browsed this prob a lot with google. Every solution I found to this prob says net stops working with this IP, but mine is working. Every solution I found I have already tried and posted here.

I found 3 solutions which I haven’t tried coz I dont know about these things and if these things will create any other prob or delete any net related settings and the net will stop working.

The solutions are -
Few people adviced WinsockFix/Reset, LSPFix/Reset, Uninstall/Install LAN card. I dont know how safe solutions these are??


P.S. Yes my network card is setup to receive it’s IP address “automatically”. ipconfig /renew gives the error unable to connect your DHCP server. Request has timed out. Any other info I can give??

One other thing, did you by any chance disable the “DHCP client” service?
And do you know what the previously working IP settings where?


for example…

No I didn’t disabled the DHCP client service. In ipconfig /all it shows DHCP enabled Yes.
The previous settings were like

IP - 192.168.x.x where x always use to change

Subnet - like you have mentioned

Gateway - If I remember started with this series only 192.168.x.x


Well if there are no firewall’s active, and the network interface shows “connected”
It should have been possible to receive an DHCP offer from the DHCP server.

If you have to give your username/password is that for a PPTP tunnel over the Ethernet LAN card?
Can you post screenshots of your network adapter properties and also from this Dial-in interface?

I am not that expert so I dont know all the technicalities. Posting the screenshots now

Attached are the Screenshots.

The Dialer is created by typing in start - run - raspppoe or pppoecfg.


[attachment deleted by admin]

Can you post a shot of “ipconfig /all” also?
If you don’t wish to post those details here, send me a PM then we can exchange it via email.

Only thing I can think of is doing a packet capture with Wireshark so we can see what lives on the ethernet interface while you are not connected to the internet (username/password dialup if).

Can you follow this post here

And then skip the “Capture filter port 80” part so we capture all that’s on the wire.

Setup should be close as many apps as possible, disconnect from the dialup, start the capture, issue an ‘ipconfig /release’ wait a few seconds and then issue a ‘ipconfig /renew’ and wait till it fails/works.

Possibly with FW set to disabled.

Save the capture, and PM me so we can exchange it.

I’m guessing the “router” downstairs is using Proxy ARP and therefore the connection functions.
You can request your ARP cache with the following command ‘arp -a’

I can use the portable wireshark??

Haven’t tried that yet, but you have to make sure you have winpcap installed also, it comes with the installer or you can get it here:


Installed but I am not getting what to do. What should I do after clicking on List the available capture interface?? will it save anything critical or sensitive info??

Not if you close down you email and other applications, It will only show “broadcast” traffic on he network interface.