Internet Won't Connect After Uninstall

Edit: Thanks for moving the thread. Also, I have followed the instructions here: and it has not improved the situation. I am still unable to connect.

I downloaded the free version. Whenever I deactivated the Firewall (to install a trusted application with less hassle), Comodo firewall would disable the internet.

Eventually I decided Comodo firewall was too advanced for my comfortable and decided I would use another firewall. However, after uninstalling Comodo free firewall, my internet won’t connect at all anymore!

I made a restore point prior to the uninstall, but now it still refuses to connect to the internet. Revo Uninstaller doesn’t recognize it either and will not remove it completely. I am very distressed right now because I cannot connect. I am using Vista 64 bit. There are other machines in my household (3) that are all currently connected to the internet and running fine, so I know it is only a problem with this machine.

Can anyone help me restore my internet connection, or explain to me why disabling/uninstalling Comodo firewall causes it to disconnect? Please help me.

For starters try installing CIS and uninstalling again. Does that help?

I had the same problem after installing the 5/18/09 update. This has happened before as well. I tried to get rid of residual Zone alarm files and the same thing happened. At this point I think Comodo Suite is too unstable to continue with.

After unisntalling go to Device Manager → View → enable “Show hidden devices” → now look under the Non-Plug and Play drivers and see if there is some Comodo left overs. When there are one or two select them one by one → right click → now choose uninstall. Reboot and see if that helped.

Having the same problem here. Tried your suggestion… didn’t help. What’s next?

Try the following tuotrial but forget about removing the Legacy keys (they are too much work):

Uninstall CIS and reboot. Then run [url=]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

Now reboot and see what happens.

Nope, didn’t work. This is the third time I’ve tried Comodo. Each time on a different machine, and two different OS’s. Comodo has failed to work properly in some way, everytime. I’ve learned my lesson, no more Comodo for me.
I guess the only way I’ll get this off my machine, and still be able to connect to the network, is to start over. Reinstall the OS, and my programs. :frowning:

It is a known thing that disabling a software firewall sometimes can cause a loss of connectivity. This has been true for many firewalls, not just Comodo. Uninstalling it should not give the same problem unless maybe you had it disabled when you uninstalled it.

There also is no reason to ever disable the Comodo firewall. Simply setting it to training mode will allow it to create rules for anything new being introduced. Just don’t forget to put it back to clean Pc or safe mode afterwards. I would suggest reinstalling it and if you still don’t like it, uninstall it without disabling it first.

Are you using a wireless connection by any instance? If so what brands of router and wireless adapter are you using?

First off, I want to say thanks for the help. This is aggravating, but that doesn’t excuse bad manners… so THANKS! :-TU

I have both a wireless, and a wired connection. After removing Comodo, neither work.
Wireless adapter is a “Atheros AR5007EG”. Router is a Linksys, and I have a Belkin N Router set up as an access point (it’s a great WAP, but a lousy as a router)

Dch48; I’ve tried uninstalling with the firewall disabled, and enabled. Makes no diff in the end.

Okay it was just a thought I had. Sorry it didn’t work.

Recently uninstalled Comodo Internet Security from Windows XP. Now none of my browsers would connect to the internet.

Looked in Device Manager > View > Show Hidden Devices > Non-Plug and Play Drivers … There was nothing Comodo related.

Ran the CIS Removal tool which the DOS screen kept saying that the file wasn’t found or Access Denied as it searched through every registry key.

The Windows XP Services.msc revealed no Comodo leftovers either.

Manual Find F search in Regedit showed CMDAGENT and other comodo registry keys, but Win XP says I don’t have access to delete Key.

Tried unlocking WinXP Administrator mode and Safe mode to delete registry keys. Still won’t let me delete registry key.

Tried to reinstall Comodo Internet Security, but installation says I’m not allowed to install it.

What gives?!?!?

You are probably bouncing at the Legacy keys.

To remove them start device manager from the command prompt with the following commands:
set devmgr_show_nonpresent_devices=1
start devmgmt.msc

Then when Device Manager has opened let is show Hidden Devices. Then you will find the Comodo drivers and can uninstall them from there.

I am not sure removing the Legacy keys will work for your problem. The firewall driver could be left behind and that could be blocking your internet access.

Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See image.