Internet still blocked after uninstalling CIS


I need some help on this as I have become quite irritated with Comodo CIS (:AGY).

I had a perfectly good working machine (2 in fact). After installing CIS (just Firewall with Defense+) I cannot connect to the internet. I have uninstalled Comodo, but to no avail- the internet is still blocked.

Both machines are running XP (SP3) with the following security apps; Avira AntiVir and Spybot Search and Destroy. I use a vodafone wireless modem and connect with the Vodafone software on both machines.
(Incidentally, I have a laptop running same security apps, but with Vista 32bt and I haven’t got problems …yet)

PLEASE help me to restore and unblock my internet connection!

Thanks in advance.

Hi, welcome to the forum epost. Sorry to hear about your troubles.

Please remember to deactivate any resident security applications when uninstalling, it does help.

Here’s a guide on how to remove anything CIS may have left behind.

Uninstall CIS and reboot. Then run Comodo System Cleaner to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

I hope that helps

Thanks for your quick response, Toggie.

I will give your suggestion a try tonight. Perhaps you can explain why all internet traffic (and network traffic to vodafone, I think) became blocked even when I disabled Comodo Firewall and Defense+ using the tray icon before I decided to uninstall?

It’s difficult to guess why that may have happened, without additional information. If you could describe the circumstances surrounding the event, with as much clarity as you can, we cam make a stab at what may have happened.

Literally as simple as this:

  1. PC, internet, everything working 100%
  2. Installed CIS (just Firewall and Defense+) without any changes to settings
  3. Reboot machine
  4. Internet blocked
  5. Disabled Defense+ and Firewall
  6. Internet still blocked
  7. Uninstalled CIS
  8. Internet still blocked

*When I say ‘internet blocked’, I mean no network traffic whatsoever.

This is the case for both machines. One of the PCs had PC Tools’ Firewall installed prior to me installing CIS (I uninstalled PC Tools’ Firewall prior to installing CIS) and everything worked fine.

Is there any explanation?

The only thing I can suggest, is that, more often than not, when things like this happen it’s because of some previous installation, be it CIS or some other product, that hasn’t been removed completely.

Please understand the nature of these kinds of product. They are able to do what they do because they have very deep hooks into the OS. If some remnant remains it can cause havoc.

May there are left overs from previous security programs. Try the following:

We are gonna take a look to see if there are some old drivers of your previous security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> do this for all drivers → reboot your computer.

When the problem persists make sure there are noauto starts from your previous security programs download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I always recommend using an uninstaller when removing software, next time please use revo uninstaller, it is free and has always helped remove leftover pieces of software.

That only works if it shows as installed in the first place, and in my case it doesn’t. There is no entry under add/remove programs and no uninstall.exe or similar file in the program files/comodo folder either, nor are there any entries or shortcuts on the menu.

I have exactly the same problem no internet access. Updated a previous version to the latest 3.10x and it failed miserably. I’ve been fighting all weekend to get internet access back, finally got it after hours and hours of searching, registry cleaning, reading, deleting and more. Then I tried reinstalling and the stupid thing did exactly the same thing! No internet access again and a failed install. I managed to activate comodo through a file in the folder even though it told me I should use the ‘repair’ folder , which placed the cmd icon in the tray at the bottom, I right clicked and and from there I disabled both defense plus and firewall. But I want this ■■■■■■ program completely off my computer now! I am disgusted with this problem after using comodo firewall for 2 years without any issues what so ever, and after reading of all the issues with uninstalling from others.

Have you tried to look at your NIC if it’s still enabled. I’m also not sure why it will be changed because it should not, but there’s no harm in checking :slight_smile:

Do the following

  1. Click Start>Run from the Windows Desktop.

  2. In the Open: field type CMD, then click OK. The Windows Command Console will appear.

  3. In the Command Console window type netsh int ip reset c:\Reset.txt

  4. Press Enter on the keyboard.

  5. In the Command Console window type netsh winsock reset

  6. Press Enter.

  7. Close the Windows Command Console and Restart the computer. Internet connectivity will be restored.