internet security essentials does not work on firefox and ice dragon [M2242]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
2:I run firefox or ice dragon
3:I do not get comodo security essentials alert

One or two sentences explaining what actually happened:
I do not get comodo security essentials alert

One or two sentences explaining what you expected to happen:
Receive alert for sites outside the domain where we are accessing;
Be alerted when using browsers based on mozilla firefox code

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Only cis installed

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
Comodo security essentials seems unable to work with firefox or ice dragon

Exact CIS version & configuration:
Comodo Internet Security v10.0.1.6209
comodo security essentials 1.1.20283.43

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
antivus: default
Auto-containment: custom (The error occurs whether in the clean install the custom)
HIPS: enable
firewall: custom

Have you made any other changes to the default config? (egs here.):
Yes, but it does not interfere with the problem. As stated, the error occurs with the default settings

Have you updated (without uninstall) from CIS 5, 6 or 7?:

Have you imported a config from a previous version of CIS:
Yes, but as stated before, the error occurs regardless of config

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
windows 10 single language 64 1607

EDIT: If run in Auto-Containment, Comodo security essentials will not display any alert (see attach)

Installed Firefox ESR 52.0.2 x32
Run COMODO Secure Shopping
Firefox does not appear in CSS.

My setup:
Windows XP Pro x32 SP3
Comodo Internet Security (updated from
COMODO Secure Shopping 1.1.405760.79
COMODO Internet Security Essentials 1.1.404762.41
COMODO System Utilities 4.0.226743.26

Can you please check if issue still occurs with CIS Thanks.

Please create a separate bug report and use the required bug reporting format thanks.

Not fixed

I was able to confirm ISE not working with firefox.

We would like to have this resolved.
When you say ISE doesn’t work, following condition should apply:

  • The https site you are browsing is not returning certificate from trusted root certificate authority

If you can still produce, we can try to work it out.


Yes ISE does not alert for fiddlers root certificate in firefox when running fiddler to decrypt HTTPS traffic. It works in IE and Chrome. Do note that firefox uses its own root cert trust store and when adding fiddlers root cert to firefoxs cert store you can browse to https sites using its certificate without any alert from ISE.

Thanks, will check as what we can do.

Please check issue with Internet Security Essentials v1.3.436779.133 - RC thanks.