internet connection block.

occasionally i get a message saying my internet connection has no or limited connection.(not exact message). during this time my firefox will not work, unless i change the comodo setting to allow all, then repair the connection and then change the setting back to custom. Does anyone no why this happens and how it can be prevented?

Any help will be much appreciated.

J J, that message is from Windows. You can always make the notifications go away, by opening your network connections, right-click the icon, select Properties, and uncheck the box for “Notify me when this connection has limited or no connectivity.” Of course, then, you won’t know what’s going on… ;D

Inasfar as why it’s happening, the following is my guess:

You are on a highspeed connection (dsl, cable, etc). You leave your computer on. Your ISP has a timeout on the IP address they issue you; it expires every so often, and needs to be updated. Your router may have settings for automatically retrieving the IP, and your setup in Windows should as well. Something may not be functioning there in the way that it should. What will happen is that your ISP updates your IP address. If you’re behind a router, your router will assign you a different, internal IP address. Windows needs to update that address; if it does not, you will have limited or no connection. Clicking on Repair updates the address and you’re back in business.

If you have your Outbound Network Rule(s) set to Log an Alert if the rule is fired, you can go to your Activity Logs and look for Network alerts showing in the Destination field an IP address ending with: dns(53). That will be the IP update.

Hope this answers your question,


ok thanks for the info. just one more question. can you tell me how i can check my outbound network rule(s).

Absolutely. Go to CPF’s Network Monitor. Double-click your TCP/UDP Out rule. Right next to the Action (set to “Allow”) is a checkbox for “Create an Alert if this Rule is Fired.” Check that box.

You can do the same for any of the rules you want; the TCP/UDP rule is where your DNS update should show. CPF may be somehow blocking that from happening automatically; if so, you’ll see it in the logs. Normally, I think the Windows default is that it (Windows) will update it automatically; however, it’s possible that Updates, or a user, have inadvertently changed that.