Internal Server Error 500 on two different VPS accounts


When I click on WHM > Plugins > Comodo WAF I am seeing this error message on two different VPS and not seeing the Comodo WAF control panel.
Comodo WAF has been correctly running on both VPS for two years. I suspect this is related to the recent cPanel 56 upgrade. Both of these VPS run Litespeed. I tried this on two different VPS (on two different physical servers) to be sure it wasn’t related to another VPS issue. Same problem on both VPS

Internal Server Error 500
No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/addon_cwaf.cgi): The subprocess reported error number 2 when it ended.
cpsrvd/ Server at {domain}.com

Please advise, what do I do?
thank you

Download the folder called comodo from /var/cpanel/cwaf/modules/CPAN/lib and upload it to usr/local/cpanel/3rdparty/perl/522/lib64/perl5/cpanel_lib

Hi Needsomehelp

That worked. I appreciate your help!

Why was it necessary for me to do this? Is it due to a cPanel change?

Is this going to be an issue with future Comodo WAF upgrades where I have to do something manually each time?

thank you very much,

Yes it’s the new cpanel update, you could of either reninstall it or do that fix. Hopefully this won’t happen again, but with all these updates you never know.

And cpanel 56 had a few big changes.

Thanks for the explanation.

Thanks, worked for me. It seems v56 broke some other things as well.

I considered about this issue and suppose it’s better to make synlink on /var/cpanel/cwaf/modules/CPAN/lib/* in necessary folder.