Interactive Services Detection" error [NBZ]

Interactive Services Detection error

The bug/issue

  1. What you did: I believe it started to occur after I had put that Windows 7 SP1 in and had installed the recent version of CIS 5.3.181415.1237
  2. What actually happened or you actually saw: Upon system start/restart I would receive these “Interactive Services Detection” warnings telling me about a bug with COMODO
  3. What you expected to happen or see: No alert
  4. How you tried to fix it & what happened: I became irritated of seeing that warning so, I just disabled the “Interactive Services Detection” service. :slight_smile:
  5. If it’s an application compatibility problem have you tried the application fixes here?:
  6. Details & exact version of any application (except CIS) involved with download link: ?
  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
  8. Any other information (eg your guess regarding the cause, with reasons):

Files appended

  1. Screenshots illustrating the bug: none
  2. Screenshots of related CIS event logs or the Defense+ Active Processes List: none
  3. A CIS config. report or file:
  4. Crash or freeze dump file:

Your set-up

  1. CIS version, AV database version & configuration used: 5.3.181415.1237, 7916, Proactive config
  2. a) Have you updated (without uninstall) from CIS 3 or 4: na Always do a fresh install between upgrades whether they be major or minor version upgrades
    b) if so, have you tried reinstalling (if not please do)?: Yes
  3. a) Have you imported a config from a previous version of CIS: No
    b) if so, have U tried a preset config (if not please do)?: na
  4. Have you made any other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.): I do not recall what “stock” configurations were, but I had tried to set everything to maximum security. i.e. “Configuration: Proactive Security” Antivirus scanner settings: all settings boxes ticked, high heuristics, 75mb maximum file size scan Firewall Behavior Settings: none Defense+ Settings: Execution Control Settings Tab all the boxes ticked and Treat unrecognized files as “blocked” Sandbox Settings tab: All Boxes Ticked and enabled
  5. Defense+, Sandbox, Firewall & AV security level: D+=Safe, Sandbox=Enabled, Firewall=Safe, AV=On Access
  6. OS version, service pack, number of bits, UAC setting, & account type: Windows 7, SP1, 32 bit, None, Admin account.
  7. Other security and utility software installed: Malwarebytes
  8. Virtual machine used: na

I always get that error when CIS crashes and the crashreporter tries to send the crash dump. It tells you that it failed and to manually send the crash dump to Comodo Bugs.

The email address is: cpfbugs[at]

The file, if produced, is and it’s located in the CisDumps folder inside the Comodo directory C:\Documents and Settings\All Users%AppData% (WinXP). Do a search to find CisDumps on your system.

Would you be able to take your time to make a bug report?


Valentin N

I do not know how to manually send it because I do not use any sort of Windows ■■■■■■ e-mail systems and have that feature turned off. So, could you give me some tips on how to send it manually?


Valentine N

do you want me to add what I had written above to make a bug report or are you referring to what L.A.R. Grizzly had written?


You don’t have an email account? If you attach your crash dump here and type out what you want me to send, I’ll send it for you.

could you give me some tips on how to send it manually?
  1. go to
  2. click on “browse”
  3. find the file you want to upload and click on that
  4. click on send
  5. when it’s done, It’ll give you a link to it
    can post that link here and write on what the problem is. Also add what version of windows your using like if it’s XP, Vista, or windows 7 and 32x or 64x hardware, if you know what it is (below)

Or another option to send it is

  1. First go here
  2. post what happened and add whether if it’s XP, Vista, or windows 7 and 32x or 64x hardware, (the problem)
  3. then click on the red icon called "Additional Options…
  4. click on “browse”
  5. Find the file to send and click “Post”

I also like to thank you for taking the time to report the problem and hopefully there will be a solution to whatever it is :slight_smile:

Okay, I believe I have figured it out. :slight_smile:

Hello, for the last couple of days I have been receiving these warnings from “Interactive Services Defection”. I have tried reinstalling CIS 5.3.xx (the newest version) but with no luck on ceasing these annoyances. Here is the messages that it contains because it will not allow me to forward these warnings to your complaint department.

Message title: COMODO Internet Security Error report
Program Path: C:\Program Files\COMODO\COMODO Internet Security\crashrep.exe

I am using Windows 7 ultimate 32 bit

I apologize. I believe I sent the wrong link. The first one was for the “cmdagent” itself and not the “crashrep.exe”. As indicated by my post.

We would very much appreciate it if you would edit your first post to create an issue report in line with the bug forum guidelines and format here. You can copy and paste the format from this topic.

To understand the reasons why we ask you to follow these guidelines please see below.

Bugs/issues can be impossible or very time consuming to fix if developers don’t have enough information to reproduce them. Since CIS is free, development time is limited. So if you want your issue fixed, please use the format below to describe it.

To avoid clutter, issues not described in the format below your post will not be moved to the ‘moderator verified’ issues topic. This means that the developers may not look at it.

Best wishes and many thanks in anticipation


Thank you for your bug report in the required format.

Moved to verified.

Thank you


Well I do not know what the problem is with my system (Windows 7 ultimate 32-bit) and with this newest 5.3 version, but I am still having those same problems as listed above. I had just done a complete uninstallation, format, and reinstallation of my OS, and I am still having conflict messages between Comodo and Windows. I have found that if I uninstall the AV portion of CIS and run just the firewall, everything seems to stop in regards of the error messages and whatnot. But, I feel like I have gone to the office without wearing pants when not running the complete CIS in its entirety. i.e. feeling half naked.

I am a loyal CIS user and hate knowing that I am unable to run the complete system as is intended. :cry: Hopefully there is a fix when a bug fix or 5.4 or so comes around…and soon I hope.

Roger :slight_smile: