Installing version 5.9


My configuration is WinXP Pro SP3 + Comodo Firewall + AVG Antivirus.

Yesterday, by mistake I started installation of latest version 5.9 over the existing version 5.8 without uninstalling it first. I was using customized installation only to install “Firewall” option for installation path "D:\Program Files\COMODO\Internet Secirity".

Previously installer used to prompt about existing version to be removed. This time the installation went through and prompted for reboot. After reboot, installation continued and again prompted for reboot. But After second reboot, cfp.exe was not found at the startup and comodo failed to load. In the comodo Installation directory, cfp.exe was missing and instead ~cfp.esxe~ was present which was the previous version.

I tried to use cfp.exe frm repair directory but it gave error something like “default theme missing”. The theme folder was empry.

Also, there was no Uninstall option in Add-Remove programs in control panel. Hence I removed the entire comodo installation directory and tried to re-install.

Now, installation completes to about 27% and then I get error 1603, and installation aborts.
(Snapshot in attached zip)
I tried to activate windows firewall but there too got the error. My system is without any firewall now.
(Snapshot in attached zip)

I tried to restore system using a previous day restore point, but wiered things are hapenning. I have 2 Administrator accounts and if I restore to previous restore point, both the Administrators lose thier administrative rights (I can not open system restore screen again, Internet access is disabled etc. giving “do not have access rights…” message) Also, windows installer does not work indicated by inability to uninstall comodo firewall from Add-Remove programs option.

Please help.

Thanks & Regards,

[attachment deleted by admin]

Please try following the steps mentioned here.

Please let us know what happens.


Thanks a lot Chiron.

I am already using Revo Uninstaller Free, but after installing v5.9, Comodo did not show either in Revo or in Add-Remove Programs under Control Panel.

But Uninstaller Tool for CIS did the trick for me. After executing this tool and rebooting, I could install the latest CIS on my laptop without any trouble. I feel secure about my Internet connection with Comodo up and running. Thanks once again!

One more point though. Previously, while Comodo Firewall being active, I could open Windows Firewall settings from Control Panel. But now, I am getting this “Due to an unidentified problem, Windows cannot display Windows Firewall settings.” error (attached in my previous post).

Is Comodo preventing Windows firewall settings to be accessed while it is active, or still something is wrong with my windows setup?

Thanks & Regards,

I don’t get that problem.

I’ll see if anyone else has a thought.

Hi radhx and Chiron,
The solution found Here is a possible fix for this issue.
Hope that works.

Hi captainsticks,

Thanks for the link, but it did not work.

Apart from few other links on the net, I followed following ones:

but still same “unidentified problem” issue exists when opening firewall.cpl.

Thanks & Regards,


As explained in previous post, I can not open Windows firewall settings. The Security Center shows at least one of the firewalls is active.

But when I tried using uTorrent, I got the Windows firewall warning popup providing the options to block/unblock/later uTorrent application. So both Windows firewall as well as Comodo are active at the same time.

I have used unblock option this time, but any help on solving this issue is appreciated.

Thanks & Regards,