Installing kernel drivers -> Rolling back action, Error 1603 (merged threads)


Operating System:
Win XP Professional SP3, 32bit,

Security programs:
no, (only Comodo Firewall 3.14.130099, which was uninstalled before installation of new version 4.0.X)

Symptoms of the bug:
When I try to install CFP 4.0.138377 (or 4.0.135239), at the end of installation, setup says: “Installing kernel drivers” …about few seconds … “Rolling back action” and then:

  • I just used batch file for error log, so you can find my CFP_error.log in attachment.

Specific steps which I tried to resolve it:
1. installed latest version of windows installer 4.5, CIS Clean-up Tool, another setup file CIS, not just CFP

  • event viewer in win showed error 1603
    not solved
    2. googling for Error 1603 msi installer, found some solutions, but not working for me
    not solved
    3. Uninstall CFP 3.14 + manually removed ALL remaining keys of Comodo in registry (really everything)
    not solved but the window of “Windows installer” error dissapeared. Window of “CIS Setup Wizard ended prematurely” just showed to me and error 1603 was in event viewer
    4. Looking for previously installed security programs - I had AVAST5 before few months - deleted all remaining entries of avast from registry + step 3
    not solved
    5. Finally found solution
  • Uninstall CIS 3.14 + deleting all keys of Comodo in registry
  • Runing Combofix + installed recovery console - it was first idea, that maybe for some reason it can help.
    And Combofix showed to me one pop-up window before start → about CD/DVD emulation drivers, that were disabled - this was second idea, about Daemon and his drivers which sometimes make problems with antivirus scanners etc.
  • Uninstall Daemon tools + deleting all keys of Daemon in registry, Restart PC

Thank you…

[attachment deleted by admin]

Try installing the latest version, v4.5, of Windows installer: .

It’s already there (V 4.5.6001.22159), because I was reading topics about installer errors etc, so I installed it before…
But ok, I tried again, download it, install it, CIS Clean-up Tool, CFP Setup (aaand I got the same message “Rolling back action”).

Do the Windows logs give any clue for further searching? Go go Control Panel → Administrative Tools → Event Viewer. The crash is most likely logged in Windows logs. If it is not there look in the applications logs.

There is nothing extra for me (5 events from begining of installation until the end …in applications log):

Event Type: Information Event Source: MsiInstaller Event Category: None Event ID: 1040 Description: Beginning a Windows Installer transaction: c:\Documents and Settings\All Users\Application Data\Comodo Downloader\CFP_Setup.msi. Client Process Id: 1704.

Event Type: Error
Event Source: Application Error
Event Category: (100)
Event ID: 1000
Faulting application msiexec.exe, version 4.5.6001.22159, faulting module MSI58.tmp, version 4.0.4167.742, fault address 0x00029bf4.

Event Type: Information
Event Source: MsiInstaller
Event Category: None
Event ID: 1042
Ending a Windows Installer transaction: c:\Documents and Settings\All Users\Application Data\Comodo Downloader\CFP_Setup.msi. Client Process Id: 1704.

Event Type: Information
Event Source: MsiInstaller
Event Category: None
Event ID: 11708
Product: COMODO Internet Security – Installation failed.

Event Type: Information
Event Source: MsiInstaller
Event Category: None
Event ID: 1033
Windows Installer installed the product. Product Name: COMODO Internet Security. Product Version: 4.0.4167.742. Product Language: 1033. Installation success or error status: 1603.

And this is from installation error log (in my first post, attachment has not been downloaded yet):

.... PublishFeatures: Feature: FeatureShortcutsCAV Action 18:16:20: PublishProduct. Publishing product information 1: cfp.ico 1: {CC6B1BB4-4E06-4A5B-A166-B371B551324B} Action 18:16:20: InstallCertificate. Installing kernel drivers... [b]Action 18:16:21: DoInstallFwAv. Installing kernel drivers... Action ended 18:16:29: InstallFinalize. Return value 3. Action 18:16:29: Rollback. Rolling back action:[/b] Rollback: Installing kernel drivers... Rollback: Installing kernel drivers... Rollback: Publishing product information Rollback: Publishing Product Features Rollback: Registering product ....

I see error 1603.

First a tip from fellow mod Ronny:

Remove HKLM\Software\Microsoft\Windows\CurrentVersion\Uninstall\Comodo Internet Security key’s.

Second a list collected by fellow mod Arkangyal:

First a tip from fellow mod Ronny:
-> this key is not there
Second a list collected by fellow mod Arkangyal:
I tried some solutions from there (google), but without any progress.

I’m still thinking, that find solution for this problem is getting impossible until the next release, update or something.

I really appreciate your help, thanks again, but I’m still waiting for advice …from anybody. :slight_smile:

I am having the exact same issue. :frowning:

Would like to know what is going on. Never have any issues installing other programs.

in CIS 4.0.138377.779 Installer with to step Installing Kernel after that it show stage Rolling Back Action and show

Comodo Internet Security Setup Wizard Ended prematurely

I installer Comodo Firewall only Firewall and not select Comodo AntiVirus because i use NOD32 AntiVirus for Protection Virus and use Comodo to Firewall only

My Computer
AMD Phenom X4
Windows XP 32Bit Service Pack 3
ESET NOD32 Antivirus 4 version 4.0.437.0
SpyBot Search & Destroy

Comodo Internet Security work without any problem and issue on my computer 3.14.1300099.587

I try to Disable NOD32 Antivirus and Close and Disable S&D TeaTime & uninstall old stable version of CIS 3.x
and restart my computer and try to installer again it show same issue

Take a look here →

The same problem with v4.0.138377, v4.0.135239. :wink:

I’m having the same issue aswell :frowning: gets to installing kernel drivers, waits a few seconds, then starts rolling back the installation

I am having the same problem when I try to install CIS 4.0.138377.779 (firewall only) on my XP SP3 machine, it gets as far as installing kernel drivers and then it starts rolling it back. It installed perfectly on my Vista machine. On both computers I first uninstalled CIS 3.14 and restarted my computers.

I thought it might be because I had DEP turned on on my XP computer, but it still didn’t work when I turned DEP off and restarted. I also noticed that the download says it is for XP SP2 and I have XP SP3, but I don’t think that could be the problem. Has anyone figured out how to fix this problem?

This happened to me on Windows 7, so i don’t think the issue is unique to Windows XP either :frowning:

I had the same error and did some tricks that … did the trick.
I had an older version of comodo, which I uninstalled, but still got the same nasty message when trying to install the new version.

Some registry tweaking solved my problem!

BE VERY CAREFUL!!! If you are not happy with reg editing DON’ T DO IT. Ask for technical advice :slight_smile:
Search through registry for keys having the word “comodo” anywhere in the name or contents and delete them.

Also delete keys having a subkey named 0000 and having a comodo content entry within.
These keys start with the word LEGACY_
BE CAREFUL only those that have a subkey 0000 having values related to comodo (you see the word comodo at least once in every 0000 subkey)
These are :
LEGACY_CMDAGENT (and 0000 subkey)
LEGACY_CMDGUARD (and 0000 subkey)
LEGACY_CMDHLP (and 0000 subkey)

You cannot delete these unless you change the permissions to everyone giving full control (right-click on main key, left click permissions, select eveyone, click full control Allow box, click ok ).
Then you can delete these “sticky entries” that cause CIS 4 to “roll back”.

CIS 4 should then install properly :-TU

BE VERY CAREFUL!!! If you are not happy with reg editing DON’ T DO IT. Ask for advice :slight_smile:

hope this helps
take care

Unfortunately, this is not worked for me. :frowning:

I’m getting tired from this problem.

Here is another angle. Follows is a tutorial to look for ,and disable, driver left overs from previously uninstalled security programs.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

I haven’t any security program installed. I was using avast before few months, so I was looking for it, but I found it just in registry - deleted all remaining entries of avast…

I forgot tell you one thing, when I deleted all entries of comodo (from previous reply, like legacy_… etc), I didn’t get error-window from Windows installer. I just got error message in CIS Setup window. But error 1603 is still in event log.

thanks this did help me :smiley:
i did run regedit search for comodo and delete all comodo folders and some mru entries
i also did kill this 000000 folders

there was only one entry which i dont remember right now
i think it was a folder named inspectors or inspect and there was something about comodo and a inspect.sys path … there i did only kill the comodo named entry and not the folder
and there was also a other folder with two comodo entries where i did only kill what was as comodo
after all the installation did work :smiley:

i hope now i killed not toomuch of the registry but i think not
and i hope the setup did correct what had to be corrected … maybe this inspect.sys entry

the firewall says that it is runing properly so i guess all is OK

i only use the firewall
for desinfection i use avira10

also i dont use this defense maybe or sandbox

i am telling that because maybe others who have install problems face other problems with different combinations

for the future i would like a comodo remover tool!
if this uninstall is not working properly they should do a remover tool as others do for theyr products
its realy hard to make a update more uncomfortable in the way as it is from 3.x to 4.x :frowning:

Hi, I am very sorry for your problem. I had the same hell for nearly a month. I hope that my solution helps.

Here goes:

  1. I am using Windows XP SP3
  2. I downloaded Combofix.exe from Bleeping Computer
  3. The download link is:
  4. If you have problem with the above link then try: ComboFix: A guide and tutorial on using ComboFix. You will find the combofix.exe link on this page
  5. I cannot emphasise strongly enough - only download Bleeping Computer’s own Combofix.exe
  6. Run Combofix.exe and follow the instructions very carefully and to the letter.
  7. Read through the Generated Report from Combofix.exe, might point out future problems
  8. Install Comodo Internet Security 4.0 Setup file.

If you are as lucky as I was your “Rolling Back Action” problem should become a thing of the past. I cannot put my finger on what exactly the problem was the in the first place, but Combofix.exe is a magic tool. It did the trick for me. It has saved me previously with a nasty rootkit problem. Funny enough I became converted to Comodo that time also, over 2 years ago.

I have made available my solution in good faith. So please use it as such. This means that you disclaim me or anyone directly or indirectly on this forum from any law suite no matter what the outcome of using the proposed solution. If you don’t agree to the dislaimer then don’t use my solution proposed.

Good luck if you use my proposed solution. I hope it works for everyone.

Thanks, I know combofix very well, you must be carefull with it, if you don’t know for what is this tool exactly. Is not like antivirus scanner definitely.

…But I can try it,… maybe… :slight_smile: