Installer hangs explorer, and other issues,

I just went to put on comodo 32-bit. First the installer said it found System Safety Monitor, which I do not have. It said this is tiny little columns where I had to widen each of them greatly and could not even get them wide enough to read it all.

Then I tried to back out, even clicked the x to get out of the installer and it would not exit even though I clicked that I wanted to exit.

I tried to use task manager to kill it but it did not show there and explorer went not responding when I then tried to exit task manager.

So right at the beginning of your installer, not even actually installing anything, it is designed so it can’t be read, finds something I do not have, won’t exit the installer, and causes explorer to go not responding so I had to log off with ctrl alt del.

I have windows xp sp2, avg free.

IIRC, nobody so far experience described issue. Most likely you have it due to improper un-installation of SSM.

Comodo would not exit its own installer but caused explorer to go down, so just detecting some remaining element of SSM should not do that, especially when Comodo still allows the option to be installed as a basic firewall.
These are bugs in the installer it seems to me.