Installer bug: Inspect.sys cannot be installed from safemode either(CFP BETA)

It’s not my style to start complaining.
But all the time I start a new thread it is messed, mixed, with other questions.
I can never solve my problems because they get messed.
I’m not a newbie on forums. Just trying to ask for a better procedure, imho.

I’ve posted here the situation:

My questions never answered:;msg93204#msg93204

So as I didn’t follow your other thread, let’s retry the normal procedure.

As I could read i your post you have some problems with the firewall, could you please tell me which version ?

Hope I can help you

Thanks Xan.
I’m using Vista Business x32 fully updated.
Installed Comodo Firewall Pro Beta.
Network part of the firewall does not work: no popups, nothing blocked. Although, the firewall is detected by Windows Security Center.
Uninstall the firewall. Installed PCTools firewall to test. No good. Uninstalled.
Tried to install Comodo beta 3 times, no way. Something is ‘left’ behind and it’s not working.
Right now, only Windows firewall is running.


I’m sorry you feel like your posts are being overlooked. We are trying to keep things clean during the beta-testing phase by keeping all bugs in one place for the developers. Thus, as we find individual posts we are merging them into the appropriate thread so that Comodo only has to look in one place. This way we don’t end up with 100 or more different threads rambling about the forum with users trying to resolve problems on a beta-project.

The primary point of beta-testing is to report reproducible bugs to the developers so that they can investigate and resolve for future releases; it is not strictly to resolve issues in the present. That said, it is first and foremost for the benefit of the developers; by default, this benefit will return to us (the users) in future releases.

I apologize if the procedure we are implementing seems a little heavy-handed; it is simply in an effort to streamline the reporting process and maximize the usability of the forums in as efficient a manner as possible. Since all the Moderators are volunteers, we are not on the forums full-time; we do this on the side and do not have the resources (ie, time) to keep track of every individual that is using this beta product. Comodo staff, on the other hand, is devoting time to the development of the product; they also do not have the resources (ie, time) to try to keep track of every individual that is using this beta product.

What steps have you taken to reproduce the problem? I see you have uninstalled/reinstalled; it seems to happen every time. Any other info?

What steps have you taken to resolve/troubleshoot the problem? If you think it is an AV-related issue, have you disabled the AV to see if it continues? Have you disabled Avast’s webshield? Have you uninstalled and reinstalled both products using SafeMode rather than in Windows normally? Have you, between uninstall/reinstall, cleaned the registry of any possible left-over entries?

These are all important things that will help the developers track down your issue, and possibly help us figure it out in the short-term as well.


PS: Other Mods - please don’t merge this thread with the main bugthread for the time being. Tnx

My suggestion:
Treat a Merged thread same as a Moved thread, ie the thread is stil there w da tag and link to the place where it was merged into.

Mods mite consider send a informing message to da thread starter.

my 2c.

I understand. Maybe I’m not only looking for beta testing but to use Comodo :slight_smile:
I’ve beta tested version 2 without problems.

I see.

Ok. I did not know (or remember) that Moderators are volunteers. I thought only the users who help are.

What info should I give? Files left behind? Registry keys? I’m not being able to troubleshoot or give the correct answers here.

I really cannot see a relationship. If I couldn’t connect, ok, WebShield from avast will play its role here, but I can connect. The problem seems to be on Comodo installation. I’ve Googled yesterday and found some users relating that installations of Comodo by second or third time won’t ‘work’ anymore. You can install the beta only once. Second installation does not work.

I’ll try to clean the registry. But it will be good to know which (if any) remains of Comodo is blocking the correct second installation.

Thanks for the help.

The only registry key that I’m aware of to commonly cause a conflict with a 2nd install of CFP v3 is this one:

HKLM\Security\Software\Comodo\Firewall Pro. Check for that and if it’s there, remove it (making sure the firewall has already been uninstalled). I’ve never personally seen this key remain if the FW is uninstalled in SafeMode. There should not, as far as I know, be any problems with installing the beta multiple times. I know in the first one there was a kill-date built into the installer, so it couldn’t be run after a certain date; that’s because it is a “testing” release and they don’t want it running around loose for the general public.

I understand that many users are actually “using” the FW, rather than just testing (perhaps especially Vista users); we’ll try to help as we can, but unfortunately that’s not something we’re really in a position to provide “support” on (in the way we do for 2.4). Obviously that will change after v3 goes final, but during beta-testing it’s limited.

It will help if you clearly define the problem for me. I’ve looked at your posts, but am not 100% sure what you’re dealing with. I see that you say Network monitor doesn’t work, and all traffic is allowed. Can you clarify exact symptoms?

As far as relationship with other security software, there may or may not be. However, modern security softwares are installing deeper into the system in order to provide higher level of protection with less use of resources. This frequently leads to strange conflicts - for some reason, competing vendors don’t seem to work together very well… :wink: Thus, the need for using SafeMode during uninstall/install. Also, disabling other applications one at a time and noting changes in the specified issue will help.

As far as troubleshooting, it’s basically a logical, step-by-step process, wherein you want to:

  1. Identify the bug (be specific - what it does when, under what circumstances)
  2. Reproduce the bug (this is a big part of #1)
  3. Work backwards (and forwards) taking steps to try to resolve it (ie, to identify the cause or source of conflict, even if you’re not able to get it to work properly)

You don’t have to be a computer geek to do this (although it might help), as long as you think logically through the process. Kind of like, if your computer won’t turn on where do you check first? To see if it’s plugged in. Yes. Next, see if there’s power at the outlet - you plug in a lamp; does it work? Yes. Is there a fuse where the cord goes into the computer? Is it good; replace the fuse if necessary to see. And so on.


PS: Any user can PM a Moderator (with a link to the relevant post) to ask for some help, if you’re not getting any, and you’re afraid it’s been overlooked. Just like we merge them, we can split it out if need to be handle it separately. Regardless of beta-testing phase, etc, we are here to help however we can.

Installation process goes ok. No errors. Boot.
Loading the firewall is ok at startup.
But opening the firewall settings I see the error in the picture.
If you try to run the diagnosis tool, I’ve got the error mentioned here:;msg93159#msg93159

I disable HIPS by now, too many popups and the main firewall is not working, i.e., there is no popup at all for any application, so, all are connecting and the computer is not protected for inbound attacks.

Can I install Comodo at Safe Mode? Will be Windows Installer service available?
I thought I can only uninstall…

So do I… although, mostly in avast forum. I’m an user in both cases, not from the staff.

[attachment deleted by admin]

Aside from the System Status notification, how are you determining that there is no Inbound protection? By default the firewall Security Level is set to Train with Safe Mode; when I had mine set to this level, I didn’t see a popup for any application, as they were all on the safelist.

Can you access the various Firewall settings/configurations? Can you make changes?

Yes, you should be able to install in SafeMode, unless Vista doesn’t allow it; I have installed & uninstalled in XP Pro using SafeMode, so I know it can be done there.


I’ve changed the default Security Level to Custom… I was expecting quite some popups… at least one for each application. Maybe I have inbound protection, but the error shown in the firewall GUI was enough to me to say I’m in trouble.

Yes, everything seems to be fine, I can change settings and they’re saved.

I’ll try soon.

Tech, I read you posts at avast forum. Were you really serious? ???
I answered your first post ASAP and other members read it as well do you still think that bugreporting should have a different procedure?
You never suggested a better procedure nor the goals an alternate procedure should archieve and the priorities that should be considered.

But if I had to guess your suggested procedure for bugreports from your posts I get:

[ol]- It is not relevant to read NOTICEs explaining why posts are moved and pointing out how to submit feedbacks

  • It is not relevant to write a meaningful title including at least a reference to the beta version used
  • It is not relevant to write all information needed to form an idea about the bug you are experiencing
  • It is not relevant to look at other posts to guess the relevant informations needed when posting a bugreport nor reading such requirements elsewhere in the board
  • It’s appropriate to wait less than 24hours and open a new topic because no one was able to solve the bug reported for a betatesting product
  • It is not relevant to copy&paste all the relevant information one was asked for in the other thread[/ol]

This is a quote from the download page listing all the information needed to post a bugreport

Since you are not a newbie I’m sure you can easily understand the problems not addressed by such type of posts:

  • Writing a meaningful title reduce confusion and it proves useful when other members are searching for a solution
  • Writing all information needed to describe an issue reduce the length of a topic and make all informations easy to follow
  • Looking at other member posts or at moderator posts that lists how to submit a request in a specific childboard give an idea on how properly interact with other members focusing on the concept that a board is a community and there should be an effort in order to make sure that other people can take advantage of the content we are providing
  • Contatcting a moderator in order to address a specific issue and to suggest a better procedure does improve the forum for the community’s sake and enforce the idea that a forum is meant for the benefit of all members, that the rules and procedures followed albeit not perfect are made in order to address a wider range of priorities and needs

So what are the motives behind all these merging:

  • This childboard is meant for betatesting so all topics refer to a beta that has a limited timespan. It is important to recognize which bug affect a certain beta.
  • All bugs are presumed to disappear in future versions so most topics will not be relevant anymore in few weeks
  • There will be other beta as well, it is imperative to keep an effort to make the board to not grow excessively long
  • It is easy for developers to watch for few threads than many. All members that have posted in a thread can easily find if that thread is updated. Still an index of all relevant bugreports or workarounds is provided by willingly volunteers in order to make the testing phase more tester friendly.

[ at ] aladinonl
the moderator frontend of SMF has many issues. The placeholder topic is only provided for moved posts and it is not really a good solution because increase the clutter and force more workload on moderators. Since there is no automatization frontend and all those placeholders should be deleted manually after a certain amount of time.
Members receive an email when a topic is moderated but here is no SMF option to send a PM as welll.
The Notice explains how to use the forum frontend to find our posts after merging/moving.
Still it is possible to write a PM to prevent newbies have a hard time finding their posts but this is somewhat related to how many posts are misplaced and how much spare time has a moderator ATM. Moderator are members as well we devote our spare time to the community we believe in but we cannot make for everithing non we can take the places or the tasks other fellow member can easily take on their own.

I’ll edit the posts. But, when I’ve wrote it you haven’t answered my post (not merged). Indeed, it’s not fair right now. Sorry, I’ll edit them.

Letting this thread alone is a way to help troubleshoot a specific problem.

Sorry, the end of your post seem that your upset with my behavior. It’s not my intention. Look, I recommend Comodo since my first usage of it. It’s running in my XP computer. Just trying to use it at Vista… the common appreciation about Comodo forum was, until you start answering my posts, the one I’ve posted on avast forum. This appreciation is not true anymore. Again, I apologyze.

I understand these reasons and the merging policy. Sorry, don’t want to start a fight. On contrary, I want my Comodo working :slight_smile:

@Tech: what is the complete list of Other security software, just on-demand

It seems you are running many kernel hooking softwares at the same time.
Please provide a Microsoft System Information Report and a GMER report.
Since V3 it is in betatesting phase in order to troubleshoot this issue you need to remove many security software you are running in order to be sure it is not a compatibility problem. Then it is needed to find out what software or what software combination cause such issues.

How do I do that?

I’ll do it.

Done :wink:

Is there any log of the installation process?

I replied to your 1st post after 5 minutes after you posted it 88)
If you look at my profile you’ll find that your subsequent posts were made at 4 AM (my local time) this forum is a worldwide one…

Exactly, I’m not upset with you so there is no need to apologize as I merely listed other points to consider.

If it was possible we could merge posts after an issue like this is solved but the posts will be disrupted anyway since SMF use the time to sort posts in a thread. We cannot create new boards to archive and categorize old posts as well.
It would be a good idea to address specific issues in a specific topic but if this take place members will start deserting the bugreporting topic.
I know that this forum is not a wiki but in the end it should provide information in a way that all members can benefit from or it will lose its true meaning. I attempted to split previous bugreporting topics by issue type but I cluttered the board more than anyone and I had to quote all posts from the bugreporting topics to the splitted ones causing much more confusion.

We are constantly searching for better solutions so we’ll warmly welcome all suggestion that will make all members’ (mods and admins included) forum experience better :-*

So I hope we can solve your issue and you can start enjoying your stay as well. :slight_smile:

I fear not but if you look at \Program files\COMODO\Firewall\Repair these are all files that COMODO installed on your system.

Microsoft System information can be started running msinfo32.exe. You may want to edit all sensible info from the txt file that you save using this app.

From a limited searching there are at least two softwares that use system drivers (it is likely they use kernel hooks too)

  • SpywareTerminator
  • PeerGuardian

There may be others as well so I hope that gmer will list all these multiple hooks drivers.

What firewall you had before V3 other than pc tools?

There is a last resort way too remove unwanted drivers that sould apply to Vista as well but don’t use it now.

Back to the problems…
Installed in Safe Mode. The network firewall isn’t working. There is no traffic being logged. No popups.
The GMER log zipped and renamed to is here.
Full profile of installed applications and operational system in a word document zipped and renamed to Belarc Computer Profile file.

I can’t find any log at \Program files\COMODO\Firewall\Repair folder…

I think Belarc log can replace it…

I’ve installed at Safe Mode, does it make any difference?

My history was: Comodo beta (I’m not sure it was working as no popups at all). Then PCTools. Then Comodo (installed and uninstalled a lot of times). I’ve used the Vista Firewall Control (standalone) once. No other firewalls besides these.

[attachment deleted by admin]

There is no log \Program files\COMODO\Firewall\Repair but these are the file V3 use to repair itself. This means that if you find any of these in another folder other than repair it was installed by comodo.

The uninstall process is handled by cfpconfg.exe -u, there is no log.

Installing in safemode prevents any software to mess with the installation process but it doesn’t solve issues generated by conflicting softwares.

Please repost the zipped files without renaming them as txt or they will not be handled correctly.