Installation Reminder Message Errors. Firewall 3.0.22.349, Windows XP SP2 Home

  1. It asks me “Why is this important?”. If you don’t know how do you expect me to know !!!
    But seriously, it looks like a link that should give me an answer from the manual when I click, but nothing happens. I noticed this at 3.0.14, and am surprised it is still with us.

Incase this problem is unique to my installation :-

It works for Firewall → View Active Connections.
This opens a window with title bar “Active Connections”, and bottom left a link
“What do these settings do?”
When I click on the link a full screen window opens at the relevant page, and
a) a new icon appears on the task bar.
If I first launch Windows Task Manager I additionally observe
b) a new Application called Comodo Firewall Pro, with a Help/query icon
c) a new process called hh.exe.

When I click the broken link on the Installation reminder :-
a) The task bar does not twitch - no new icon
b) Windows Task Manager Application tab does not twitch, no new application
c) Windows Task Manager Processes tab does not twitch, no new process.

  1. when it goes away (whether I click NO or just wait for it to time out) it only stays away for half a minute - I thought it was supposed to remind me at 5 minute intervals.

Regards
Alan

Install mode is part of Comodo and doesnt require an additional service. The tray icon always stays the same and this is normal. Some have suggested to change it. The install mode pop up Windows for happens about every 2-3 min or so. I never seen anywhere a time limit. The process hh.exe comes when ever you open up a help file system so just click allow and remember.

The help file link is not broken. When you click on “what do these settings do” it requires that the hh.exe process be aloud to run. Normal.

Hi

The link is broken for me, and always has been (I think I switched from 2.4 to 3.0.14.xxx about 1 week after it was first released.)

This link has always been broken, and never given any pop-ups, at least on my system :-
“Why is this important?”

This link has always worked, and never given any pop-ups :-
“What do these settings do?”

The “broken” link seems to do nothing at all - not a twitch in Windows Task Manager.
The working link launches hh.exe as a process and Comodo help manual as the name of an application, and both the application and process terminate when I close the help window

I never had a pop-up for hh.exe, so I do not understand how or why Defense+ created a rule for C:\Windows\hh.exe, but for whatever reason it has created a rule.
It has a Custom Policy for which :-
Protection settings “Active” has NO selected for all 4 items;
Protection settings “Exceptions” has “no items to show” for all 4 modify buttons;
Access Rights “Default Action” has “Ask” selected against all 15 Access Names;
Access Rights “Settings” has 8 off “Modify” buttons that are totally [empty];
Access Rights “Settings” has 1 “Modify” button for “Protected COM interfaces”, which shows :-
Under Allowed :- Shell.Explorer.2
Under Blocked :- [empty]

I do not see any reason why hh.exe should be blocked for one link and not the other.
The only possibilities I can think of are that :-

  1. “Shell.Explorer.2” has a significance which I do not understand, and this significance is affected by whether help is requested from a stable link that persists until manual cancellation of the window displaying that link, or if it is a fleeting link that is in a window that is on a 30 second time-out;
  2. the “broken” link is incomplete, at least for my installation.

The “broken” link works to a very limitted degree, in that when I hover over it, the colour changes from Blue to Green, just the the links which work properly.

Is there a tremendous significance in my very recent observation :-
All the working links commence with a question mark in a Blue circle (which remains blue during hover),
and my “broken” link has no such question mark and no such circle ?
Does Windows XP need the question mark before it launches hh.exe ?
Is it possible the developer responsible for this bit of code did not quite finish one evening, and removed the question mark so its absence would remind him the next morning to finish the job !!!

Re. the reminder message repetition rate :-

I think I read “5 minutes” somewhere, either in the Comodo Forum or in the Help manual - can’t remember.
I have just done a quick search on the forum - search rejected because each word must have two or more letters.
Tried “Five minutes” and got a lot of irrelevant hits, BUT one good hit :-
https://forums.comodo.com/empty-t12182.0.html;msg94163#msg94163
Which shows that in October 2007 “Little Mac” had also read this 5 minute period somewhere.

Regards
Alan

I have Comodo running on 2 pc’s. One laptop and one desktop both using XP SP3. Link works. Also my work laptop using Comodo works. Is hh.exe blocked in D+? Have you tried doing a complete uninstall and reinstall? Also 4 family members are using Comodo with no troubles and I sent out an email with the link problem and all of them said it works. BTW no reason to type up a book with every thread. Too much to read. Do you have another PC to try out Comodo on? You can manually add hh.exe to D+. I have 2 entries of it.

[attachment deleted by admin]

Sorry Alan not being a ■■■■ but you have made several lengthy posts and complaints. Maybe its not Comodo but your pc. Maybe its time to reformat. Just a suggestion.

Hi

Defense+ has one custom policy rule for C:\Windows\hh.exe
It has nothing for C:\Windows\System32\HH.EXE

The custom policy is ASK against everything, but it never asks for anything - it just works when it works, and not for my “broken” link.
This item is one of a large number of applications which are all grouped together beneath “All Applications” which is also ASK against everything, but is modified for ctfmon.exe. Could this have an impact ?

I have only this one computer, an Acer Laptop which has had SP2 for a few years.

I was responsible for many posts last year when I had extreme difficulty removing version 2.4 legacy registry keys, but eventually I completely purged the system of all traces of Comodo, and was able to install version 3.0.xxx.
The first 3.0.xxx had this broken link problem. It continued with 3.0.14.xxx. Last month I downloaded the “Patch” that should have upgraded me from 3.0.14 to 3.0.22, but when I ran it I was told it was an incompatible version. Does this indicate your “patch” is a bit dodgy, or that my Windows is a bit broken ?

I used the full installation, and upon first run it offered to remove the old firewall, which went well, and the next run got a good installation. This also had the broken link problem. After several weeks experimentation upon various things, concluding with an investigation into System Restore interactions with Comodo, I repaired any experimental damage be restoring the partition image I archived before I installed 3.0.22. This gave me the original 3.0.14. Three days ago I once more installed 3.0.22, and again the link is “broken”.
When 3.0.18 was quite new it got installed - again link was broken. Due to stealth mode problems I quickly reverted to 3.0.14.

I have lost count of the number of times I have installed 3.0.xx.xxx, and each time the link was “broken”.

I have been running with Defense+ at SAFE MODE.
Just tried “Disabled” and then invoked installation mode - the link remained “broken”
Just tried “Clean Mode” then installation - again still “broken”.

Does it need .NET Framework, or Java ?

Perhaps a reformat is in order - the problem is Acer supplied all the Microsoft software pre-installed - I have no installation discs, only a recover disc set.

For many months I thought this “broken” link was a cosmetic defect which just needed a couple of lines of code to fix and thereby remove the cosmetic blemish. I do not understand why hh.exe runs for one link and not another, but I am happy to let you “close” or “lock” this bug report - anything but suffer a reformat !!!

Regards
Alan

Have you tried updating your .NETFramework? I have an older Gateway lying around and when I bought it I got a full set of recovery cd’s and a Windows CD.

Hi

.NET Framework is on my todo list.

My Security patches are fully up to date with the exception of KB928365 for .NET Framework 2, which has some problem, and I cannot un-install because some installer catalogue file is missing so Windows does not know in what order to remove stuff.

I did find a brute force program that stripped .NET Framework 2, but then CCleaner reported thousands of “missing shared DLLs” so I reverted to my previous partition image.

I will be trying again quite soon.

Regards
Alan

You really need to reformat.

There is no CFP prereq for .NET. You do not need it for CFP.
I have been able to live without .NET on XP so far.

Al