Installation Not Automatically Allowed Despite Inst Digital Sig In TVL [M1031]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    On my system I can reproduce it
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:I want to install a software that digtally signed. CIS showed me pop-ups. But I learnt from bogdanr, This software already in TVL
    2:I cleared the unrecognized files list and I reset the sandbox
    3:I want to installed it for checking again, result is same
    4:I reported it bogdanr also, He said to me report it as a bug
  • If not obvious, what U expected to happen:
    This software should be installed as pure water. But it was not…CIS connot block the trusted vendor application. There must be a TVL issue again.
  • If a software compatibility problem have U tried the conflict FAQ?:
    I don’t think so.
  • Any software except CIS/OS involved? If so - name, & exact version:
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    I think issue is from Comodo Cloud

[ol]- Exact CIS version & configuration:
CIS v 7.0.317799.4142

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    HIPS : OFF , Sandbox : Fully Virtualized , Viruscope : ON , FW : ON , AV : ON
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No. Clean installition
    [li]if so, have U tried a a clean reinstall - if not please do?:
    Yes. It is a clean install.
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:
    Yes. Still same
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 7 Home Basic x64 SP1 , Admin , no VM used, it is a real system.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Webroot SecureAnywhere Antivirus. This issue does not concern this software. ( a real companion antivirus )

Download link of the software : -

[attachment deleted by admin]

I just checked and it installs fine on my system. Please try reinstalling CIS by following the advice I give in this topic and, after reinstalling, do not change any settings. Then see if it still reproduces. If it does we can explore this issue further, but first I need to rule out problems with your particular installation.

Thank you.

Hello Chiron,

I just reinstalled CIS, I did not change any settings it is in default. This is inform to you everything is fine now. :-TU

But I do not know why this issue is happen ???


That’s fine. It was probably just that something got corrupted. I’ll move this to Resolved.

If the issue re-appears let me know and I can move this back.


0.Diagnostics report as attachment to your post Attached
1.The full product and its version e.g. CIS v 7.0.317799.4142
2.Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one. Windows 7 home basic x64 - SP 1
3.List all the configuration changes you did. Are you using Default configuration? If no, whats the difference? Too many. .cfgx file attached
4. Did you install over a previous version without uninstalling first, or import a previous configuration file? No. It was a clean install
5.Other Security, Sandboxing or Utility Software Installed Webroot SecureAnywhere Ativirus (companion Antivirus product) , CCleaner
6.Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step.
This question is crucial as well. The most valuable report is the one with precise, separate, numbered, reproduction steps.

a) I want to install a soft. CIS showed me pop-ups. But I learnt from bogdanr, This software already in TVL
b) I cleared the unrecognized files list and I reset the sandbox
c) I want to installed it for checking again, result is same
d) I reported it bogdanr also, He said to me report it as a bug
9. What you expected to see or happen when you carried out these steps, and why (if not obvious) This software should be installed as pure water. But it was not…There must be a TVL issue again.

Download link of software : -

[attachment deleted by admin]

Thank you for reporting this again. However, as CIS is no longer in Beta I will have to ask that you edit your first post so that it is in the format provided here.

I will also move this bug report to the main bug reporting board for continued processing. Let me know if you have any questions.


Hello Chiron,

I edited the title. Should I change the subject content in the first post according to new bug post ?


Yes. Please do change the content in the first post.



I just edited the first post and I changed the attachments.


I think you had misunderstood me about the format. I have now copied the correct format into the first post. Please edit that post. Then replace each question mark with your response. Use preview to see what it will look like.

If you have any questions please let me know.

Thank you.


Thank you for guide.

Thank you. Please provide a link to where bogdanr said to report it as a bug.

He said it via PM after my question about this issue.

Thank you. I have modified the title. Does this correctly summarize this issue?

The title now fits perfectly :-TU

Thanks Chiron :slight_smile:


Is your File Ratting Settings like in the attached picture? Just to clear out some possibilities.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

The devs have not been able to replicate this. Are you able to replicate this bug with the new Beta version?

If so, please make a Full Dump of the process during installation by using KillSwitch. Then upload that file to a file sharing site and include the download link in your reply. Please let me know if you have any questions.

Thank you.

As the devs have not been able to replicate this, and there has been no response, I am assuming this is likely fixed. Therefore, I will move this to Resolved.

If this is still happening on your computer please respond and let me know.