Inbound connections (Help with MIRC)

Hello, recently I went on a vacation, and when I came back I couldn’t connect IRC and many other related issues such as online function of games.

When I use Comodo’s connection moniter, I see this:

Is this a problem of my firewall settings or?

For a more concise explanation of my problem see here:

Have you tried restarting your modem? For online gaming see my sticky.

Well, I’m in a university room and the only control I have over my connection is whether or not to plug the network cable into the network point in my room.

However, I have asked the IT services staff here as to whether they’re blocking the connections and they denied it, going so far as to send personnel to my room with a laptop, plugging it into the network point and connecting to MIRC successfully (thereafter telling me good luck and leaving).

What are your CFP3 rules for MIRC? Could server IP addresses have changed while you were gone? The picture shows 3 established outbound TCP connections and another port listening for an inbound connection-Is that port open? What about D+ rules?

Sorry sded is your man for this.

  1. I have tried using many rulesets, but even the trusted application ruleset leads to the same result.

  2. I can’t connect to ANY IRC server at all, so it’s hardly a server IP address problem.

  3. I disable D+.

Anyway, I’m just wondering if it’s a Comodo firewall problem because I’m trying to narrow down my diagnostics, it doesn’t necessarily have to be Comodo at fault.

If someone could point me to an ideal Comodo IRC ruleset, that would be great (the only one I could find for the forums is the one for DCC and file transfers).

Unfortunately I don’t remember what MIRC requires-haven’t used it in a while- But the firewall has allowed you to establish 3 TCP connections to the MIRC servers on port 6667, and setting it to trusted should allow the inbound unless your global rules block it. What are your global rules? If they end in a block all inbound, try removing it and see if you can connect. Do you get any log entries from Comodo? May need to look for a MIRC user to help-try changing the thread title to include MIRC and someone should pop up, since it is a very popular program. :slight_smile:

I only have one global rule which is the:

Block ICMP in from IP Any to IP Any Where ICMP Message Is ECHO Request.

I would erase the current global rule also-don’t remember what IRC does with ping, but it is used sometimes. Other thing to try is to let CFP3 make its own rules. Does anything show up as blocked in your application rules? Erase any rules you have for MIRC and put CFP3 into training mode. Then when you try to establish a connection, you should get a popup asking you to allow whatever it is MIRC needs to do to connect. Usually you need to erase D+ rules and put D+ is training mode too, but not if you are sure it is really disabled. In the meantime, hope a MIRC user shows up soon for you. :slight_smile: You might also take a look at this thread;topicseen for a hint. User says he had to put the rules under WOS to make MIRC work.

Actually, it I exit the firewall, does it still exert control over which ports are open/closed?