Impossible to install virtual network adapter(such as TAP and Wintun)

Hello to all.
When CIS is installed(or Comodo firewall) - occur error when try to install VPN software such as openvpn, wireguard or
third party VPN software. The error occurs on virtual network adapter installing step.
Stopping antivirus or firewall not help.
After uninstalling CIS - VPN software installation passes without any problems.
TAP installer failed on Windows 10 1709 with 2.4.6 - Page 2 - OpenVPN Support Forum the same problem is described on the official openvpn forum

Ideally, you should have your VPN Adapter installed prior to installing Comodo. It may be possible to add the firewall driver to the adapter manally as I’ve shown here:;msg905421#msg905421

The firewall drivers are added to the network adapters on Comodo’s initial installation so the only workarounds I’ve discovered so far are to manually add the CF service to the adapter or do a fresh install.

i’m caught this issue during my vpn app update ))
it was so hard to stay in China without a VPN


I spent a lot of time searching, uninstalling, tweaking the registry, files permissions…

  • Can’t install OpenVPN TAP (hang during install, but TAP present after killing MSIEXEC and reboot)
  • Can’t install HyperV virtual switch (error 80070005)
  • Can’t install VMware virtual ethernet, (It’s hang for a while, it finishes, the device is in error! But the virtual ethernet device is present and functional after a reboot, )
  • Can’t install/ update Pure VPN (It use open VPN TAP and another type of virtual ethernet)

I have uninstalled Comodo and I can now install all the adapters I want.
Reinstall is OK and everything functional. But what a pain if I want to change something in Virtual networks (private or not).

So Comodo prevent installation of ALL the virtual adapters…

And of course after reinstall (icon is missing in systray…)
Developpers, you have a lot of work to make Comodo as good as it was before the last updates… :wink:

Eric Cryptid, I haven’t understant you answer, it appears to be not the subjet…

Hi Slepnir & Metathes,

Thank you for reporting.
Have you disabled “Trust files installed by trusted installer” option? Please check.

And please confirm the download link of software that you are using.

These 2 can be added to that list:

Edit: It’s the installation itself that’s the problem. Mullvad has a warning to disable Comodo to avoid the problems - obviously not knowing how hard that is! I tried everything, but eventually gave up and just do a quick uninstall and reinstall of CIS. Wireguard still doesn’t allow the Comodo Firewall river, but that’s a Wireguard problem no doubt. They’ll probably change that as more VPN’s seem to be adopting it

It works well for me
I am using VpnTunnel

looks like disabling Comodo firewall driver in network adapter properties before vpn/virtual network adapter installation can resolve this issue. have a one positive case.

This issue is similar to other reported issue with CIS blocking WSLv2 from working correctly due to blocking the creation of hyper-v virtual network adapter, fix was included in 7092 so it should also apply to this topic as well.


Yes, these are the download links I’ve used: (VMware workstation including the virtual network editor)

I’m agree that this issue is similar to other reported issue with CIS blocking WSLv2, I have read it after my first post.

Have you disabled "Trust files installed by trusted installer" option? Please check.
- HIPS is disable - I've disable "activate cloud search" including "Trust files installed by trusted installer" (In french, i have disable: "Activer la recherche dans le cloud" and "Evaluer les applications en fonction de leur evaluation de l'éditeur")

Comodo v12.2.2.7098

I’ve haven’t test to disable comodo driver in my main ethernet adapter. I have uninstalled Comodo, installed all I need reinstalled comodo and reapply my configuration.
Now I’m waiting for next release hoping it will be fixed (including the missing systray icon too).

It works with Protonvpn

To be able to install Network TAPs you’ll need to be running until Comodo fix their software. (Which should also fix problems with Windows Subsystem for Linux as it is most likely related to the Hyper-V Virtual Switch).

Fixed in

Good afternoon, I have (windows 10 20h2 + Comodo Firewall). All my friends have this problem and there is no solution! If you install OpenVPN or VirtualBox or nordvpn and more, then the programs hang on creating a virtual adapter! Only removing the СomodoFW helps! :cry:

Please use the search as this has been known about and is fixed with the latest version.