IIS Inetinfo.exe configuration for local

Hi all,

I’ve checked the forums and couldn’t find an answer to how to set up IIS for Comodo.

By default it seems to allow IIS on the local machine, which is fine, but I can’t find where it explicitly allows it! I tried blocking inetinfo.exe and comodo still allowed local requests.

Can someone explain how I might gain explicit control over IIS and the server rights? Do network rules superceded Application rules?

Thanks! I develop locally and need to be assured that my firewall isn’t letting others in.

I have probably a similar problem. When I access my home pages, the Comodo firewall automatically rejects the TCP IN: 80 request for Inetinfo.exe and does not display any alert although inetinfo.exe is not in the list of blocked/allowed applications. Specifying inetinfo.exe as a trusted application does not help.

Is there anybody, who knows how to handle these problems?

In this link https://forums.comodo.com/index.php/topic,6167.0.html there’s a tutorial/explanation about Comodo’s layered rules. This should help clarify things for you a bit, I think.

caveatrob, you’re going to want to go to Security/Advanced/Miscellaneous and uncheck the 2nd box, “Do not show alerts for applications certified by Comodo.” Then reboot. This disables the Comodo safelist, which will cause you to get all sorts of system-generated traffic alerts from CFP - svchost, system, services, inetinfo, and probably every other bleedin’ process that Windows can cook up! If you want full control, that’s how you’ll get it. You may go insane, but you’ll have full control… :wink:

besoft, it sounds like you need to create a Network Monitor rule to Allow TCP In on Destination Port 80 (Network Monitor events do not generate popup alerts). Make sure in Application Monitor that your receiving application (in this case, inetinfo.exe) is set to Allow TCP In on Destination Port 80.