If you have IE8, READ THIS!

Not sure if this is simply an isolated issue or a widespread bug, but today when I let Vista update to IE8 (via windows update), suddenly the firewall refused to block any outbound traffic.

Even on ‘block all’ this simple leak test (it doesn’t do anything tricky, it’s just like any other program that connects to the 'net… and Comodo had always blocked it correctly in the past) got through. Even Malwarebyte’s anti-malware could update in block all mode. I uninstalled CIS, rebooted, reinstalled it and now it works fine.

Just somthing to watch out for if you upgrade to IE8 on Vista. If you are on Vista and have let it install IE8 within windows update, please try the leaktest and post your results. Link for leaktest:


I have IE 8 installed and CPF is blocking the leak test…Block all mode works too. I am running just the firewall not the anti virus.

Hmm… I’m using the firewall and defence+ without the antivirus as well.

A couple of questions to help isolate what’s different between us.

What version of CIS are you using? I’m on 3.8.65951.477, with D+ and Firewall only, no AV (using AVG 8.5)

What version of Vista are you running? I’m on Home Premium 32bit.

Lastly, how did you install IE8? Did you use a standalone installer, or did you use windows update? (I used windows update)

Did you also install Office service Pack two? I did that at the same time.

What version of flash player are you using? IE8 had a problem with my current version and I upgraded it straight after, so perhaps that was it. Would you be willing to try updating flash player here? (If you don’t mind potentially having to re-install the firewall)
I would check my flash player version but my 'net is too slow at the moment (went over download limit)

I’m running Vista Home Premium SP 1 32 bit

Our CIS versions are the same

I’m running Avast AV home…(Free version)

IE 8 was installed through windows update…No problem with the flash player…Version 10 installed

I don’t have Office installed…

Maybe you could uninstall and reinstall CIS if all else fails…Good luck

As I mentioned before, I reinstalled CIS and it fixed it, but I had a very similar problem happen today. Firewall popups simply would not show, and while ‘block all’ mode blocked all my regular programs, somthing strange was happening with the leak tester. The leak tester can still tell if the firewall blocks it even when not connected to the internet (I’m not sure how this works). As such, the leaktester was reporting it penetrated it even when the ethernet cable was unplugged. Regardless of whether this was a fault with the leaktester or not, the firewall was still not showing any popups even when I removed a rule for an application and ran it.

I uninstalled CIS (again!), ran the Comodo cleanup tool (which caused the security centre to stop recognizing avg until 2 reboots later) and reinstalled CIS. Once again, everything is fine but I can’t tell how long for.