hi folks sorry im new to all this,but when i click on ie -firewall asks 4 ok of 5 pages is this right(my ie default is google)it never used to ask.Also i get svc host allow or deny what does this mean.any help would be appreciated nice 1

The title of your post includes the word “i e x p l o r e r”, but you haven’t mentioned this in the body of the post. If youare getting alerts about iexplorer.exe, then you have malware on your system.

The Windows desktop shell is called “explorer.exe”.

Internet Explorer is called “iexplore.exe”

There is no Windows executable called “iexplorer.exe”

Ewen :slight_smile:

sorry to be so naive[still learning] (:NRD)but should i disable internet explorer in application monitor.i thought internet explorer was the default windows browser.I have comodo boclean running+have done a virus scan with avira classic which came up clean.Could a program be using internet explorer to connect to the net whithout my knowledge.Is there a way to see if internet explorer has any other add ons except my google default.Any info on this would help a lot.NICE 1

He clearly said his IE default (Page I’d assume) is GOOGLE which is a start page online in a browser which I would assume is IExplorer from the IE part. IE being short for IExplorer, Just a thought, he did mention it… (:WIN) Don’t be too hard on the newbie’s, might scare em away…

Thanks for that mate,{IExplorer-google}is my browser start page.Are the pages asked for, the programs linked to Iexplorer like email etc or is it possible i have malware.Im trying to learn about this type of thing but its a fair bit to get your head round.If i disable Iexplorer i cant access this great world wide web,any suggestions for an alternative browser or am i trying to run before i can walk.MUCHO THANKS.
P.S.Sorry if im being a pain in da nether regions :o

NP, Riggers, OPERA is by far the best of the best as far as Browsers go. Secure, easy to use, tabbed browsing with Java built-in and easy to disable if need be. Wand for passwords so if you can’t remember them all NP, Many other features, including a speed dial so you can have 9 Homepages shown in frames so you can access them at a click. Anyway, check it out you might even like the built in mail client, rss feed reader, widgets and the rest…
Cheers Mate.

Welcome to the forums, riggers ~

I’ll try to explain briefly (wish me luck…;))

The “4 of 5” is simply because the application is repeatedly trying faster than the user can respond. You can control the depth of this response in Security/Advanced/Miscellaneous, something like “show # of alerts” or somesuch.

Ewen’s trying to point out that being precise when naming applications is very important. The reason being, there are various malware (trojan, virus, etc) that try to masquerade as known applications or processes. iexplore.exe = Internet Explorer, explorer.exe = the Windows shell and svchost.exe = a vital Windows generic host process.

On the other hand, iexplorer.exe, explore.exe, svhost.exe all = malware. You will note there is only one letter different in each of these; this makes it easy to slip under the user’s “radar.”

As for whether the popups you are seeing are safe or not, we can’t say without knowing exactly what they say. If you could capture a screenshot, crop to the popup, and attach to your post (using the Additional Options - bold red font - directly below the textbox) as an image file (jpg, png, or gif), this will help us tremendously. If you need/want help with the whole screenshot thing, just let us know and we’ll direct you to step-by-step instructions on that.


Kudo’s to you, I totally missed that which was being said by Panic, My Apologies to him. Indeed the topic heading is IExplorer+Comodo…My Bad (:SHY). I assumed (What an ass I am) instead of reading…Cheers and Kudo’s…

Thanks very much for the advise folks,think i will try a differant browser{opera sounds good},and i will look out for snydy names of programs{done by wners].

If i change my browser do i then allow it in application monitor manually or will the search pick it up.
Im getting it slowly so thanks again for your help :Beer

When you add a new app, it should be found when run and HIPS will ask if you approve it, and your firewall will then ask if it can connect…IT SHOULD go like that…Cheers from Canada! (:WAV)

The first time you run the browser, you should get an alert from the firewall, probably like Opera.exe with a parent application of explorer.exe is trying to connect… You will want to Allow with Remember checked.

Here’s something else to do. If you’re not using a local proxy (like proxomitron - you’ll know if you are), you should go to Security/Advanced/Miscellaneous and make sure both boxes are checked for “Skip loopback…” - both TCP and UDP (only one is by default, for local proxy security). Do that before running your browser.


NP :wink:

Thanks for all the help folks i’ll give it a go,im sure if i fall off you guys can help me back up. if i start a new app and comodo asks and i tick remember this answer will that application go in application monitor and then allways allow it or will it still ask for a while{not thick like me}. cs5 is there much snow in banf yet as me sister travels over from england soon

If you click REMEMBER and ALLOW to an applicatioj alert, this should create a permenent rule in the Application Monitor.

Ewen :slight_smile:

To be honest not right at the moment. That will give you up to date forcast’s for Banff. I LOVE COMODO. That’s just to keep it close to ON TOPIC. Sry Mod’s. In future though Riggers, gotta stay On topic in forum’s, I don’t think the rules allow for personal notes here. PM me though in future, I have NP with that. Cheerio, pip pip, and all that rot… (:WIN)

Hey cs5,

A little bit of off topic is OK, providing it ends up drifting back on topic. :wink: While we all want these forums to be the best they can be, we don’t want to end up as dry as a cup of powdered toast, like some other security forums.

Ewen :slight_smile:

Thanks for the input folks,managed to get firefox browser up + running but now all web pages seem to go through it.Is this just the way firefox is or am i missing summat.Tried “opera” but not to keen,any suggestions on a browser which doesn’t act as a server to all web pages,as even when i click on help to connect to commodo site direct it goes through firefox.

Top 1 for all the help+guidance so far (V) i hope soon i can help newbies like you all helped me

kindest regards


p.s. I also blocked iexplore in application monitor

If your issue is related to an “act as a server” message for firefox, this is a different deal, and not a cause for concern. It simply means that FF is prepared to establish a connection, and is using the localhost/loopback for internal communications.

If you are not using a local proxy (such as proxomitron - which you’d know if you were) it is safe to disable loopback monitoring. Go to Security/Advanced/Miscellaneous and make sure both boxes are checked for “Skip loopback…” - TCP and UDP (only one is by default, for local proxy security).


Thank LM, i think what you describe is the case.I have checked “Skip loopback” for both TCP and UDP and all seems fine.

Also my dad recently bought a CA-firewall/antivirus program and commodo dumps on it from a great height,any idea if commodo are to bring out such a program as i would gladly pay for it if they did.

Regards Matty.

Aside from that you have set your Firefox to be your default browser which is why when you click on links it opens it in firefox regardless, (All except Microsoft links IE MSN Messenger, etc.) You can set any browser as default in your Internet options which you will find in the tools menu at the top of your browser, and also in your control panel. Hope it helps…BTW, did you try Opera?